wvdial: update to wvstreams 4.5.1
This commit is contained in:
parent
0dd259bd12
commit
9c56de2044
@ -1,4 +1,3 @@
|
||||
ca2d01b5c727d7ea62aa20b81028998b wvdial-1.60.patch
|
||||
6fede1ca598a9905983a059f985807d5 wvdial-1.60.patch
|
||||
27fbbde89f8fd9f6e735a8efa5217fc9 wvdial-1.60.tar.gz
|
||||
907b0cba8931553d848620ea16f006b9 wvstreams-4.4.1.tar.gz
|
||||
0a1e0f921075774ad97a7aac2fb4421c wvstreams-gcc43.patch
|
||||
d092f6a80d38d361cb7a6d54d7699678 wvstreams-4.5.1.tar.gz
|
||||
|
@ -5,23 +5,18 @@
|
||||
|
||||
name=wvdial
|
||||
version=1.60
|
||||
release=3
|
||||
release=4
|
||||
source=(http://alumnit.ca/download/$name-$version.tar.gz \
|
||||
http://wvstreams.googlecode.com/files/wvstreams-4.4.1.tar.gz \
|
||||
$name-$version.patch wvstreams-gcc43.patch)
|
||||
http://wvstreams.googlecode.com/files/wvstreams-4.5.1.tar.gz \
|
||||
$name-$version.patch)
|
||||
|
||||
build() {
|
||||
cd wvstreams-4.4.1
|
||||
|
||||
patch -p1 -i $SRC/wvstreams-gcc43.patch
|
||||
./configure --prefix=/usr \
|
||||
--enable-verbose \
|
||||
--without-{pam,tcl,qt}
|
||||
make
|
||||
ln -s ../xplc/include/xplc include/xplc
|
||||
cd wvstreams-4.5.1
|
||||
./configure --prefix=/usr --without-{pam,tcl,qt,dbus}
|
||||
make -j1
|
||||
|
||||
cd $SRC/$name-$version
|
||||
patch -p1 < $SRC/$name-$version.patch
|
||||
make CXXOPTS="$CXXFLAGS" WVS=$SRC/wvstreams-4.4.1
|
||||
patch -p1 -i $SRC/$name-$version.patch
|
||||
make -j1 CXXOPTS="$CXXFLAGS" WVS=$SRC/wvstreams-4.5.1
|
||||
make DESTDIR=$PKG install
|
||||
}
|
||||
|
@ -23,7 +23,7 @@ diff -Nru wvdial-1.60.orig/Makefile wvdial-1.60/Makefile
|
||||
- $(error WvStreams does not appear to be installed)
|
||||
-endif
|
||||
-LIBS+=$(PC_LIBS)
|
||||
+LIBS = $(WVS)/libuniconf.a $(WVS)/libwvstreams.a $(WVS)/libwvutils.a $(WVS)/libwvbase.a $(WVS)/xplc/libxplc-cxx.a -lcrypto -lssl
|
||||
+LIBS = $(WVS)/libwvstatic.a -lstdc++ -lcrypto -lssl
|
||||
|
||||
BINDIR=${prefix}/bin
|
||||
-MANDIR=${prefix}/share/man
|
||||
|
@ -1,26 +0,0 @@
|
||||
http://sources.gentoo.org/viewcvs.py/gentoo-x86/net-libs/wvstreams/files/wvstreams-4.4.1-gcc43.patch?rev=1.1&view=markup
|
||||
|
||||
diff -ur wvstreams-4.4.1.orig/include/uniconfkey.h wvstreams-4.4.1/include/uniconfkey.h
|
||||
--- wvstreams-4.4.1.orig/include/uniconfkey.h 2007-07-19 22:22:49.000000000 +0100
|
||||
+++ wvstreams-4.4.1/include/uniconfkey.h 2008-06-17 19:54:46.000000000 +0100
|
||||
@@ -7,6 +7,8 @@
|
||||
#ifndef __UNICONFKEY_H
|
||||
#define __UNICONFKEY_H
|
||||
|
||||
+#include <climits>
|
||||
+
|
||||
#include "wvstring.h"
|
||||
#include "wvlinklist.h"
|
||||
|
||||
diff -ur wvstreams-4.4.1.orig/include/wvserialize.h wvstreams-4.4.1/include/wvserialize.h
|
||||
--- wvstreams-4.4.1.orig/include/wvserialize.h 2007-08-17 06:15:30.000000000 +0100
|
||||
+++ wvstreams-4.4.1/include/wvserialize.h 2008-06-17 20:02:28.000000000 +0100
|
||||
@@ -349,7 +349,7 @@
|
||||
* except as the last character.
|
||||
*/
|
||||
template <>
|
||||
-extern WvString _wv_deserialize<WvString>(WvBuf &buf);
|
||||
+WvString _wv_deserialize<WvString>(WvBuf &buf);
|
||||
|
||||
|
||||
/** Deserialize a WvBuf. */
|
Loading…
x
Reference in New Issue
Block a user