fetchmail: fix build with openssl 1.1.1

This commit is contained in:
Juergen Daubert 2019-01-17 09:20:29 +01:00
parent f73d5b59dc
commit a02f17115b
3 changed files with 29 additions and 4 deletions

View File

@ -1,5 +1,6 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/STKnEB8uQ5Qoop85f0eyj32GFQwgiDl5X9oRMs4/lTtJuEQMLeWpyMlDcwEPGjnNtfnc2Eaz14CgHOA6p28Aw4=
SHA256 (Pkgfile) = f2b2d7cdc21b0445673b89ce8578ab61aeee64a7a801151e10b0fd5f5a44d548
RWSE3ohX2g5d/Y0n3vcwSPgXj3R4bxyNKLUuwVUz99sDAYw5pKiCqWqyTpKUqO0IhQXny6vBJm1YiVZp8uYkN6ogmdDtxF9/JAA=
SHA256 (Pkgfile) = f8f9a42c504f55f24f5600c1518d15d1be9a4578a7b9bc5d97b750ea697da0e6
SHA256 (.footprint) = c52f9b61b3ffbab88aa941546c7721245d6c825056bd4948b84b94966203996d
SHA256 (fetchmail-6.3.26.tar.xz) = 79b4c54cdbaf02c1a9a691d9948fcb1a77a1591a813e904283a8b614b757e850
SHA256 (disable-sslv3.patch) = b6494164df52de475930c964ba8b293482deb29a817d31af7ff9816a30db8d31

View File

@ -5,12 +5,16 @@
name=fetchmail
version=6.3.26
release=2
source=(http://downloads.sourceforge.net/project/$name/branch_6.3/$name-$version.tar.xz)
release=3
source=(http://downloads.sourceforge.net/project/$name/branch_6.3/$name-$version.tar.xz
disable-sslv3.patch)
build() {
cd $name-$version
# fix build with openssl 1.1.1
patch -p1 -i $SRC/disable-sslv3.patch
# don't build python stuff
sed -i '19,21s/^/#/' Makefile.am
autoreconf -vi

View File

@ -0,0 +1,20 @@
diff -u -r fetchmail-6.3.26/socket.c fetchmail-6.3.26-nossl3/socket.c
--- fetchmail-6.3.26/socket.c 2013-04-23 22:00:45.000000000 +0200
+++ fetchmail-6.3.26-nossl3/socket.c 2016-03-03 18:18:46.688881618 +0100
@@ -907,14 +907,11 @@
_ssl_context[sock] = NULL;
if(myproto) {
if(!strcasecmp("ssl2",myproto)) {
-#if HAVE_DECL_SSLV2_CLIENT_METHOD + 0 > 0
- _ctx[sock] = SSL_CTX_new(SSLv2_client_method());
-#else
report(stderr, GT_("Your operating system does not support SSLv2.\n"));
return -1;
-#endif
} else if(!strcasecmp("ssl3",myproto)) {
- _ctx[sock] = SSL_CTX_new(SSLv3_client_method());
+ report(stderr, GT_("Your operating system does not support SSLv3.\n"));
+ return -1;
} else if(!strcasecmp("tls1",myproto)) {
_ctx[sock] = SSL_CTX_new(TLSv1_client_method());
} else if (!strcasecmp("ssl23",myproto)) {