libidn: updated to 1.34. New maintainer

This commit is contained in:
Fredrik Rinnestam 2018-04-02 14:39:10 +02:00
parent 3992b4b27f
commit b15816c937
5 changed files with 13 additions and 50 deletions

View File

@ -11,9 +11,9 @@ drwxr-xr-x root/root usr/include/
-rw-r--r-- root/root usr/include/tld.h
drwxr-xr-x root/root usr/lib/
-rwxr-xr-x root/root usr/lib/libidn.la
lrwxrwxrwx root/root usr/lib/libidn.so -> libidn.so.11.6.16
lrwxrwxrwx root/root usr/lib/libidn.so.11 -> libidn.so.11.6.16
-rwxr-xr-x root/root usr/lib/libidn.so.11.6.16
lrwxrwxrwx root/root usr/lib/libidn.so -> libidn.so.11.6.18
lrwxrwxrwx root/root usr/lib/libidn.so.11 -> libidn.so.11.6.18
-rwxr-xr-x root/root usr/lib/libidn.so.11.6.18
drwxr-xr-x root/root usr/lib/pkgconfig/
-rw-r--r-- root/root usr/lib/pkgconfig/libidn.pc
drwxr-xr-x root/root usr/share/

View File

@ -1,2 +1 @@
cd02b28cd6b74d7e55055651003dfcf4 CVE-2017-14062.patch
a9aa7e003665de9c82bd3f9fc6ccf308 libidn-1.33.tar.gz
a829db6cd0b85733017c20a50bf10798 libidn-1.34.tar.gz

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/XzfkvpoUogWAcNTzXOg8hIykW9+oa298BOCD/60VV/zBtCGx/1AC/ulsdgOM4qV46JvoWtWNKviPjm7dkAPdA4=
SHA256 (Pkgfile) = 3b2004727e755c55320c76255d6b8b1c2260c08244832e8cc4b9c59e3fbc004b
SHA256 (.footprint) = 8b7ff628d35d714b967f076a8e848cc7c6963129dc2ef9064b13e64e4a9ecf1d
SHA256 (libidn-1.33.tar.gz) = 44a7aab635bb721ceef6beecc4d49dfd19478325e1b47f3196f7d2acc4930e19
SHA256 (CVE-2017-14062.patch) = 9dd36fddcfe60b8feb958bab4538054134187a52c98c15ec43362b63eaf69ac4
RWSE3ohX2g5d/dn1j1sBBtA+EuJYMrYe7bL2gK5mJ/VhCRNRHCtiX8Er352C8eLBPF6fy1w5VPmLTy0rOxCCIJ5FZjnJwM89wgA=
SHA256 (Pkgfile) = 9d9098155c05e14ac19251c15e40629e58df9b8d6c1be7d611f1f7a8fe724f47
SHA256 (.footprint) = c3c3f998d1de592745c76cda52e808a4f5e7288c12d0221d5f8be2c03816e4c9
SHA256 (libidn-1.34.tar.gz) = 3719e2975f2fb28605df3479c380af2cf4ab4e919e1506527e4c7670afff6e3c

View File

@ -1,29 +0,0 @@
--- a/lib/punycode.c 2016-01-14 21:42:33.000000000 +0800
+++ b/lib/punycode.c 2018-01-12 11:36:58.027226633 +0800
@@ -88,11 +88,11 @@ enum
/* point (for use in representing integers) in the range 0 to */
/* base-1, or base if cp does not represent a value. */
-static punycode_uint
-decode_digit (punycode_uint cp)
+static unsigned
+decode_digit (int cp)
{
- return cp - 48 < 10 ? cp - 22 : cp - 65 < 26 ? cp - 65 :
- cp - 97 < 26 ? cp - 97 : base;
+ return (unsigned) (cp - 48 < 10 ? cp - 22 : cp - 65 < 26 ? cp - 65 :
+ cp - 97 < 26 ? cp - 97 : base);
}
/* encode_digit(d,flag) returns the basic code point whose value */
--- a/tests/tst_idna.c 2016-01-14 21:42:33.000000000 +0800
+++ b/tests/tst_idna.c 2018-01-12 11:36:58.027226633 +0800
@@ -211,7 +211,7 @@ static const struct idna idna[] = {
'x', 'n', '-', '-', 'f', 'o', 0x3067},
IDNA_ACE_PREFIX "too long too long too long too long too long too "
"long too long too long too long too long ", 0,
- IDNA_CONTAINS_ACE_PREFIX, IDNA_PUNYCODE_ERROR}
+ IDNA_CONTAINS_ACE_PREFIX, IDNA_INVALID_LENGTH}
};
void

View File

@ -1,21 +1,15 @@
# Description: Provides support for IETF Internationalized Domain Names (IDN).
# URL: http://www.gnu.org/software/libidn/
# Maintainer: Jose V Beneyto, sepen at crux dot nu
# Packager: Daniel Mueller, daniel at danm dot de
# Maintainer: Fredrik Rinnestam, fredrik at crux.guru
name=libidn
version=1.33
release=2
source=(http://ftp.gnu.org/gnu/$name/$name-$version.tar.gz
CVE-2017-14062.patch)
version=1.34
release=1
source=(http://ftp.gnu.org/gnu/$name/$name-$version.tar.gz)
build() {
cd $name-$version
patch -p1 -i $SRC/CVE-2017-14062.patch
sed -i '/^SUBDIRS/s/doc//' Makefile.am
autoreconf
./configure \
--prefix=/usr \
--disable-nls \
@ -27,5 +21,5 @@ build() {
install -d $PKG/usr/share/man/man{1,3}
install -m 0644 doc/*.1 $PKG/usr/share/man/man1
install -m 0644 doc/man/*.3 $PKG/usr/share/man/man3
rm -r $PKG/usr/share/info
}