sqlite3: update to 3.6.9

See my comments included in the patch and the upstream bugreport
at http://www.sqlite.org/cvstrac/tktview?tn=3583
This commit is contained in:
Juergen Daubert 2009-01-14 17:27:07 +01:00
parent cd68c324b7
commit b37c435ff6
4 changed files with 61 additions and 12 deletions

View File

@ -12,6 +12,3 @@ lrwxrwxrwx root/root usr/lib/libsqlite3.so.0 -> libsqlite3.so.0.8.6
-rwxr-xr-x root/root usr/lib/libsqlite3.so.0.8.6
drwxr-xr-x root/root usr/lib/pkgconfig/
-rw-r--r-- root/root usr/lib/pkgconfig/sqlite3.pc
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/sqlite3.1.gz

View File

@ -1 +1,2 @@
5223d1f459b608ed8c2c54f8847f8e1a sqlite-3.6.7.tar.gz
6abc9800c2ae448adfa71861caeee637 sqlite-amalgamation-3.6.9.tar.gz
06d5c38bac4e5589e559f1e1e9bb67ea sqlite3-pkgconfig.patch

View File

@ -4,18 +4,23 @@
# Depends on: ncurses, readline
name=sqlite3
version=3.6.7
version=3.6.9
release=1
source=(http://www.sqlite.org/sqlite-$version.tar.gz)
source=(http://www.sqlite.org/sqlite-amalgamation-$version.tar.gz
sqlite3-pkgconfig.patch)
build () {
cd sqlite-$version
./configure --prefix=/usr \
--enable-threadsafe \
--disable-tcl
cd sqlite-amalgamation-$version
patch -p1 -i $SRC/sqlite3-pkgconfig.patch
autoreconf -f
libtoolize -fq
CFLAGS="$CFLAGS -DNDEBUG" \
./configure --prefix=/usr
make
make DESTDIR=$PKG install
install -d $PKG/usr/man/man1
install -m 644 sqlite3.1 $PKG/usr/man/man1
}

View File

@ -0,0 +1,46 @@
# Patch to add support for the pkgconfig-file sqlite3.pc, needed by at least firefox.
# See my upstream bugreport here http://www.sqlite.org/cvstrac/tktview?tn=3583.
# We want the amalgamation version of the sources, because we otherwise have to install
# tcl to build sqlite3 with special options like -DSQLITE_ENABLE_FTS3=1
#
# 2009-01-14 jue
diff -Nru sqlite-amalgamation-3.6.9.orig/Makefile.am sqlite-amalgamation-3.6.9/Makefile.am
--- sqlite-amalgamation-3.6.9.orig/Makefile.am 2009-01-14 14:13:11.000000000 +0100
+++ sqlite-amalgamation-3.6.9/Makefile.am 2009-01-14 17:04:30.000000000 +0100
@@ -12,3 +12,5 @@
include_HEADERS = sqlite3.h sqlite3ext.h
+pkgconfigdir = ${libdir}/pkgconfig
+pkgconfig_DATA = sqlite3.pc
diff -Nru sqlite-amalgamation-3.6.9.orig/configure.ac sqlite-amalgamation-3.6.9/configure.ac
--- sqlite-amalgamation-3.6.9.orig/configure.ac 2009-01-14 14:13:11.000000000 +0100
+++ sqlite-amalgamation-3.6.9/configure.ac 2009-01-14 14:58:02.000000000 +0100
@@ -24,7 +24,8 @@
# Check for library functions that SQLite can optionally use.
AC_CHECK_FUNCS([fdatasync usleep fullfsync localtime_r gmtime_r])
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile sqlite3.pc])
+AC_SUBST(BUILD_CFLAGS)
#-----------------------------------------------------------------------
# --enable-readline
diff -Nru sqlite-amalgamation-3.6.9.orig/sqlite3.pc.in sqlite-amalgamation-3.6.9/sqlite3.pc.in
--- sqlite-amalgamation-3.6.9.orig/sqlite3.pc.in 1970-01-01 01:00:00.000000000 +0100
+++ sqlite-amalgamation-3.6.9/sqlite3.pc.in 2009-01-14 12:49:13.000000000 +0100
@@ -0,0 +1,13 @@
+# Package Information for pkg-config
+
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: SQLite
+Description: SQL database engine
+Version: @VERSION@
+Libs: -L${libdir} -lsqlite3
+Libs.private: @LIBS@
+Cflags: -I${includedir}