readded wvdial

This commit is contained in:
Simone Rota 2006-02-23 17:13:51 +00:00
parent 5de4d88a95
commit b564fd74e3
4 changed files with 94 additions and 0 deletions

15
wvdial/.footprint Normal file
View File

@ -0,0 +1,15 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/ppp/
drwxr-xr-x root/root etc/ppp/peers/
-rw-r--r-- root/root etc/ppp/peers/wvdial
-rw-r--r-- root/root etc/ppp/peers/wvdial-pipe
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/wvdial
-rwxr-xr-x root/root usr/bin/wvdialconf
drwxr-xr-x root/root usr/man/
drwxr-xr-x root/root usr/man/man1/
-rw-r--r-- root/root usr/man/man1/wvdial.1.gz
-rw-r--r-- root/root usr/man/man1/wvdialconf.1.gz
drwxr-xr-x root/root usr/man/man5/
-rw-r--r-- root/root usr/man/man5/wvdial.conf.5.gz

3
wvdial/.md5sum Normal file
View File

@ -0,0 +1,3 @@
d084772c96db6c52371e36b29d95f332 wvdial-1.55.patch
747b135ca909129a14c777cf53ed3df0 wvdial-1.55.tar.gz
103230cb9926cb8f3f4d8dc8584f3b9c wvstreams-4.2.2.tar.gz

25
wvdial/Pkgfile Normal file
View File

@ -0,0 +1,25 @@
# Description: Weave Dial - PPP dialer
# URL: http://open.nit.ca/wiki/?page=WvDial
# Maintainer: Jürgen Daubert <juergen.daubert@t-online.de>
# Depends on: ppp, openssl
name=wvdial
version=1.55
release=1
source=(http://open.nit.ca/download/$name-$version.tar.gz \
http://open.nit.ca/download/wvstreams-4.2.2.tar.gz \
$name-$version.patch)
build() {
cd wvstreams-4.2.2
./configure --prefix=/usr \
--enable-verbose \
--without-{bdb,qdbm,pam,tcl,telephony,swig,qt}
make
ln -s ../xplc/include/xplc include/xplc
cd $SRC/$name-$version
patch -p1 < $SRC/$name-$version.patch
make CXXOPTS="$CXXFLAGS" WVS=$SRC/wvstreams-4.2.2
make DESTDIR=$PKG install
}

51
wvdial/wvdial-1.55.patch Normal file
View File

@ -0,0 +1,51 @@
diff -Nru wvdial-1.55.orig/Makefile wvdial-1.55/Makefile
--- wvdial-1.55.orig/Makefile 2006-02-12 19:22:27.000000000 +0100
+++ wvdial-1.55/Makefile 2006-02-12 20:55:49.000000000 +0100
@@ -1,30 +1,22 @@
ifeq ($(TOPDIR),)
TOPDIR=.
- prefix=/usr/local
- WVSTREAMS_INC=
- WVSTREAMS_LIB=
+ prefix=$(DESTDIR)/usr
+ WVSTREAMS_INC=$(WVS)/include
+ WVSTREAMS_LIB=$(WVS)
WVSTREAMS_BIN=$(prefix)/bin
WVSTREAMS_SRC=.
- PC_CFLAGS=$(shell pkg-config --cflags libwvstreams)
- ifeq ($(PC_CFLAGS),)
- $(error WvStreams does not appear to be installed)
- endif
- CPPFLAGS+=$(PC_CFLAGS)
-
- PC_LIBS=$(shell pkg-config --libs libwvstreams)
- ifeq ($(PC_LIBS),)
- $(error WvStreams does not appear to be installed)
- endif
- LIBS+=$(PC_LIBS)
+ LIBS = $(WVS)/libuniconf.a $(WVS)/libwvstreams.a $(WVS)/libwvutils.a $(WVS)/libwvbase.a $(WVS)/xplc/libxplc-cxx.a -lcrypto -lssl
else
XPATH=$(TOPDIR)/src
endif
BINDIR=${prefix}/bin
-MANDIR=${prefix}/share/man
-PPPDIR=/etc/ppp/peers
+MANDIR=${prefix}/man
+PPPDIR=$(DESTDIR)/etc/ppp/peers
+
+VERBOSE=1
include $(TOPDIR)/wvrules.mk
@@ -38,7 +30,7 @@
ifeq ($(WVSTREAMS_LIB),)
LIBUNICONF:=-luniconf
endif
-wvdial wvdialconf papchaptest pppmon: wvdial.a $(LIBUNICONF)
+wvdial wvdialconf papchaptest pppmon: wvdial.a
install-bin: all
[ -d ${BINDIR} ] || install -d ${BINDIR}