lilo: use static binary compiled with gcc8

This commit is contained in:
Juergen Daubert 2020-10-24 16:51:06 +00:00
parent 8593ff0f67
commit b6a88c45ec
5 changed files with 18 additions and 100 deletions

View File

@ -1,4 +1,3 @@
drwxr-xr-x root/root boot/
drwxr-xr-x root/root etc/
-rw-r--r-- root/root etc/lilo.conf
drwxr-xr-x root/root sbin/

View File

@ -1,7 +1,7 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/RetMUSrQ9c0N2Q8dOavSlC3ddyMoqde4yo4qqWExmEv4A8vPXbzLCQzFVIvm3/Gjwa4CP1McpFqEasPrjwswwU=
SHA256 (Pkgfile) = e0454e96028b8f91bb7b05ec05f69211efeb488b583b0bbb12545b8a012b2ee7
SHA256 (.footprint) = 0ec118c0155abdcd2374fbf1454e52ff9619bd8e4017e0268345b82a95c3173c
RWSE3ohX2g5d/QWsxpsjtV8F3edfKjljHTIkf2GZlyZCuiTRGYWm3spDTglb0x7ywyOg9em4QEj7bRKUSUd2Par8+aUEOq7iQAQ=
SHA256 (Pkgfile) = 9f72a9a6fae89ec476fdde18764af9e7eb6b116af9d42059a23ab3e291020068
SHA256 (.footprint) = 2636eb9a632a396d76be391c98b290b240695dc0c130acd66d3080ed3baf080c
SHA256 (lilo-24.2.tar.gz) = e158f19de4560c935ebe0507c21b79bff17618b9230d8076fe8c5fff9fdbd5b1
SHA256 (lilo-config.patch) = ad7d556831938a9d4441b2cd4f3ad9c06210cd1c9f1b27356b2b19c5b042996b
SHA256 (lilo.static) = 8058aa189ed1781e6b933cd4e2f02fc3b44442f78ed0332986cb8165290218e8
SHA256 (lilo.conf) = 2b9b399a3318920a45208e98bdcd521e7a7c2cdfc7e398d628295c3c93ebecb7

View File

@ -1,18 +1,24 @@
# Description: LInux boot LOader
# URL: https://www.joonet.de/lilo/
# Maintainer: CRUX System Team, core-ports at crux dot nu
# Depends on: libdevmapper bin86
name=lilo
version=24.2
release=2
release=3
source=(https://www.joonet.de/lilo/ftp/sources/$name-$version.tar.gz \
$name-config.patch lilo.conf)
lilo.static lilo.conf)
build() {
cd $name-$version
patch -p1 -i $SRC/$name-config.patch
make CFLAGS="$CFLAGS -fcommon" all
make DESTDIR=$PKG install
install -m 644 $SRC/lilo.conf $PKG/etc
cd $name-$version
install -d $PKG/{sbin,usr/sbin,etc,usr/share/man/man{5,8}}
install -m 755 $SRC/lilo.static $PKG/sbin/lilo
install -m 755 scripts/lilo-uuid-diskid $PKG/usr/sbin
install -m 755 keytab-lilo.pl $PKG/usr/sbin/keytab-lilo
install -m 644 man/{keytab-lilo,lilo-uuid-diskid,lilo}.8 $PKG/usr/share/man/man8
install -m 644 man/*.5 $PKG/usr/share/man/man5
install -m 644 $SRC/lilo.conf $PKG/etc
}

View File

@ -1,87 +0,0 @@
diff -Nru lilo-24.1.orig/Makefile lilo-24.1/Makefile
--- lilo-24.1.orig/Makefile 2014-10-19 09:31:10.871906282 +0200
+++ lilo-24.1/Makefile 2014-10-19 09:33:40.570016027 +0200
@@ -12,7 +12,6 @@
#
all: test
make -C src all
- make -C images all
#
# make help
@@ -45,7 +44,6 @@
#
alles: test
$(MAKE) -C src alles
- $(MAKE) -C images all
#
# documentation files
@@ -104,12 +102,8 @@
#
install: all
$(MAKE) -C src install
- $(MAKE) -C images install
- $(MAKE) -C hooks install
- $(MAKE) -C sample install
$(MAKE) -C scripts install
$(MAKE) -C man install
- $(MAKE) -C dos install
tidy:
$(MAKE) -C src tidy
diff -Nru lilo-24.1.orig/make.vars lilo-24.1/make.vars
--- lilo-24.1.orig/make.vars 2015-07-26 16:42:59.144497363 +0200
+++ lilo-24.1/make.vars 2015-07-26 16:43:49.518277641 +0200
@@ -70,7 +70,7 @@
# XL_SECS=n Support for extra large (non-standard) floppies.
CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
- -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVIRTUAL \
-DMDPRAID -DDEVMAPPER
# set the following if you wish LILO.COM to be installed
diff -Nru lilo-24.1.orig/man/Makefile lilo-24.1/man/Makefile
--- lilo-24.1.orig/man/Makefile 2014-10-19 09:31:10.868573065 +0200
+++ lilo-24.1/man/Makefile 2014-10-19 09:31:38.537607503 +0200
@@ -12,7 +12,7 @@
PODFILES := lilo-uuid-diskid lilo liloconfig
MANFILES5 := lilo.conf
-MANFILES8 := keytab-lilo lilo-uuid-diskid lilo liloconfig mkrescue
+MANFILES8 := keytab-lilo lilo-uuid-diskid lilo
all:
diff -Nru lilo-24.1.orig/scripts/Makefile lilo-24.1/scripts/Makefile
--- lilo-24.1.orig/scripts/Makefile 2014-10-19 09:31:10.871906282 +0200
+++ lilo-24.1/scripts/Makefile 2014-10-19 09:31:38.537607503 +0200
@@ -15,7 +15,6 @@
install:
mkdir -p $$DESTDIR$(USRSBIN_DIR)
- install -m 0755 liloconfig $$DESTDIR$(USRSBIN_DIR)
install -m 0755 lilo-uuid-diskid $$DESTDIR$(USRSBIN_DIR)
clean:
diff -Nru lilo-24.1.orig/src/Makefile lilo-24.1/src/Makefile
--- lilo-24.1.orig/src/Makefile 2014-10-19 09:31:10.868573065 +0200
+++ lilo-24.1/src/Makefile 2014-10-19 09:34:59.340601665 +0200
@@ -47,7 +47,7 @@
#
# everything needed to run, just short of installation
#
-all: lilo bootsect.b
+all: lilo
#
# everything above plus the statically linked version
@@ -248,7 +248,6 @@
strip lilo.static; \
cp lilo.static $$DESTDIR$(SBIN_DIR)/lilo.static; \
fi
- cp ../mkrescue $$DESTDIR$(USRSBIN_DIR)/mkrescue
cp ../keytab-lilo.pl $$DESTDIR$(USRSBIN_DIR)/keytab-lilo
dep:

BIN
lilo/lilo.static Executable file

Binary file not shown.