libxml2-python: update to 2.6.31

This commit is contained in:
Juergen Daubert 2008-01-12 10:43:30 +01:00
parent d9af1d4d9b
commit bee0edda5f
3 changed files with 8 additions and 17 deletions

View File

@ -1,2 +1,2 @@
460e6d853e824da700d698532e57316b libxml2-2.6.30.tar.gz
b46c239bb79b1d29fea848019a21ba75 libxml2-python-config.patch
714b0683b1ec4bdc63bc356d729f9b18 libxml2-2.6.31.tar.gz
57c08b8a87eb678d5727e2ef6fb4b566 libxml2-python-config.patch

View File

@ -4,14 +4,14 @@
# Depends on: python, libxml2
name=libxml2-python
version=2.6.30
version=2.6.31
release=1
source=(ftp://xmlsoft.org/libxml2/libxml2-$version.tar.gz \
$name-config.patch)
build () {
cd libxml2-$version
patch -p1 < $SRC/$name-config.patch
patch -p1 -i $SRC/$name-config.patch
./configure --prefix=/usr
cd python
make

View File

@ -1,16 +1,7 @@
diff -Nru libxml2-2.6.27.orig/python/Makefile.in libxml2-2.6.27/python/Makefile.in
--- libxml2-2.6.27.orig/python/Makefile.in 2006-10-26 08:07:43.000000000 +0200
+++ libxml2-2.6.27/python/Makefile.in 2006-10-26 08:10:57.000000000 +0200
@@ -56,7 +56,7 @@
am__installdirs = "$(DESTDIR)$(pythondir)"
pythonLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(python_LTLIBRARIES)
-@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 = $(top_builddir)/libxml2.la
+@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 = $(libdir)/libxml2.la
@WITH_PYTHON_TRUE@libxml2mod_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
am__libxml2mod_la_SOURCES_DIST = libxml.c types.c libxml2-py.c
@WITH_PYTHON_TRUE@am_libxml2mod_la_OBJECTS = libxml.lo types.lo \
@@ -326,7 +326,7 @@
diff -Nru libxml2-2.6.31.orig/python/Makefile.in libxml2-2.6.31/python/Makefile.in
--- libxml2-2.6.31.orig/python/Makefile.in 2008-01-11 12:19:19.000000000 +0100
+++ libxml2-2.6.31/python/Makefile.in 2008-01-11 12:25:21.000000000 +0100
@@ -330,7 +330,7 @@
libxml2mod_la_LDFLAGS = @CYGWIN_EXTRA_LDFLAGS@ @WIN32_EXTRA_LDFLAGS@ -module -avoid-version
@WITH_PYTHON_TRUE@mylibs = \