libcap: updated to 2.16
This commit is contained in:
parent
cf471ad516
commit
ca03a8df43
@ -5,8 +5,8 @@ drwxr-xr-x root/root usr/include/sys/
|
||||
drwxr-xr-x root/root usr/lib/
|
||||
-rw-r--r-- root/root usr/lib/libcap.a
|
||||
lrwxrwxrwx root/root usr/lib/libcap.so -> libcap.so.2
|
||||
lrwxrwxrwx root/root usr/lib/libcap.so.2 -> libcap.so.2.13
|
||||
-rw-r--r-- root/root usr/lib/libcap.so.2.13
|
||||
lrwxrwxrwx root/root usr/lib/libcap.so.2 -> libcap.so.2.16
|
||||
-rw-r--r-- root/root usr/lib/libcap.so.2.16
|
||||
drwxr-xr-x root/root usr/man/
|
||||
drwxr-xr-x root/root usr/man/man3/
|
||||
-rw-r--r-- root/root usr/man/man3/cap_clear.3.gz
|
||||
|
@ -1,2 +1,2 @@
|
||||
c67b2d105f48d9413f0f5a16b2162f70 libcap-2.13-makefile.patch
|
||||
6a28953b509582cbefc296e98b84bbd6 libcap-2.13.tar.gz
|
||||
0d1cee9631768d29b43f450832668687 libcap-2.16-makefile.patch
|
||||
9e075fda242c4070ba76407064c13302 libcap-2.16.tar.gz
|
||||
|
@ -4,7 +4,7 @@
|
||||
# Depends on: libattr
|
||||
|
||||
name=libcap
|
||||
version=2.13
|
||||
version=2.16
|
||||
release=1
|
||||
source=(ftp://ftp.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.6/libcap-$version.tar.gz
|
||||
$name-$version-makefile.patch)
|
||||
@ -12,7 +12,7 @@ source=(ftp://ftp.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.6/libc
|
||||
build () {
|
||||
cd libcap-$version
|
||||
|
||||
patch -p1 -i $SRC/$name-$version-makefile.patch
|
||||
patch -p0 -i $SRC/$name-$version-makefile.patch
|
||||
|
||||
make
|
||||
make \
|
||||
|
@ -1,18 +0,0 @@
|
||||
diff -ruN libcap-2.11.orig/libcap/Makefile libcap-2.11/libcap/Makefile
|
||||
--- libcap-2.11.orig/libcap/Makefile 2008-07-30 22:06:54.000000000 +0300
|
||||
+++ libcap-2.11/libcap/Makefile 2008-07-30 22:07:52.000000000 +0300
|
||||
@@ -21,13 +21,8 @@
|
||||
|
||||
all: $(MINLIBNAME) $(STALIBNAME)
|
||||
|
||||
-ifeq ($(shell gperf --version > /dev/null 2>&1 && echo yes),yes)
|
||||
-USE_GPERF_OUTPUT = $(GPERF_OUTPUT)
|
||||
-INCLUDE_GPERF_OUTPUT = -include $(GPERF_OUTPUT)
|
||||
-endif
|
||||
-
|
||||
_makenames: _makenames.c cap_names.sed
|
||||
- $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
|
||||
+ $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@ -I./include
|
||||
|
||||
cap_names.h: _makenames
|
||||
./_makenames > cap_names.h
|
14
libcap/libcap-2.16-makefile.patch
Normal file
14
libcap/libcap-2.16-makefile.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- libcap/Makefile~ 2008-12-04 09:03:12.000000000 +0200
|
||||
+++ libcap/Makefile 2009-01-12 17:17:07.000000000 +0200
|
||||
@@ -27,11 +27,6 @@
|
||||
|
||||
all: $(MINLIBNAME) $(STALIBNAME)
|
||||
|
||||
-ifeq ($(shell gperf --version > /dev/null 2>&1 && echo yes),yes)
|
||||
-USE_GPERF_OUTPUT = $(GPERF_OUTPUT)
|
||||
-INCLUDE_GPERF_OUTPUT = -include $(GPERF_OUTPUT)
|
||||
-endif
|
||||
-
|
||||
_makenames: _makenames.c cap_names.list.h
|
||||
$(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
|
||||
|
Loading…
x
Reference in New Issue
Block a user