mysql: update to 5.1.48, fix for gcc 4.5

This commit is contained in:
Juergen Daubert 2010-06-19 10:23:53 +02:00
parent 83c4cc637c
commit ccbb3f298b
3 changed files with 38 additions and 4 deletions

View File

@ -1,3 +1,4 @@
907c4ac28c33b2508750bca8a29ef9b9 my.cnf
02b9964b3966832f3d6bc87524bfd73f mysql-5.1.47.tar.gz
a2ffcadadfd8b2cda80f3dddbc8933fe mysql-5.1-gcc45-apicheck.patch
d04c54d1cfbd8c6c8650c8d078f885b2 mysql-5.1.48.tar.gz
642a596f13ebd7e459c5ff2fd382f06b mysqld

View File

@ -4,14 +4,16 @@
# Depends on: ncurses readline zlib
name=mysql
version=5.1.47
version=5.1.48
release=1
source=(http://mirror.switch.ch/mirror/mysql/Downloads/MySQL-5.1/$name-$version.tar.gz \
my.cnf mysqld)
my.cnf mysqld mysql-5.1-gcc45-apicheck.patch)
build () {
cd $name-$version
patch -p1 -i $SRC/mysql-5.1-gcc45-apicheck.patch
./configure --prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/sbin \
@ -22,7 +24,7 @@ build () {
--without-{readline,debug,docs} \
--with-ssl \
--with-plugins=myisam,innobase
make
make DESTDIR=$PKG install

View File

@ -0,0 +1,31 @@
# http://bugs.mysql.com/bug.php?id=52514
diff -Nru mysql-5.1.47.orig/Makefile.in mysql-5.1.47/Makefile.in
--- mysql-5.1.47.orig/Makefile.in 2010-05-25 21:39:20.411815787 +0200
+++ mysql-5.1.47/Makefile.in 2010-05-25 21:40:35.201822062 +0200
@@ -1132,24 +1132,7 @@
$(MAKE) abi_headers="$^" do_abi_check
do_abi_check:
- set -ex; \
- for file in $(abi_headers); do \
- @CC@ -E -nostdinc -dI \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/include/mysql \
- -I$(top_srcdir)/sql \
- -I$(top_builddir)/include \
- -I$(top_builddir)/include/mysql \
- -I$(top_builddir)/sql \
- $$file 2>/dev/null | \
- @SED@ -e '/^# /d' \
- -e '/^[ ]*$$/d' \
- -e '/^#pragma GCC set_debug_pwd/d' \
- -e '/^#ident/d' > \
- $(top_builddir)/abi_check.out; \
- @DIFF@ -w $$file.pp $(top_builddir)/abi_check.out; \
- @RM@ $(top_builddir)/abi_check.out; \
- done
+ echo "Skipping do_abi_check"
# Don't update the files from bitkeeper
%::SCCS/s.%