ccache: updated cmake syntax

This commit is contained in:
Tim Biermann 2022-01-08 13:43:41 +01:00
parent b7e42810c4
commit d6bc6f6204
3 changed files with 5 additions and 35 deletions

View File

@ -1,6 +1,6 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/djDWwTtmDXRCKptWmDOjV4Nf2t0gbkabsZ5OgzUckR1AvO6MZFGB9TIvQiKLzwnizEx/hfayF18d7M7AmnTkwA=
SHA256 (Pkgfile) = d91917ae4a550597699c1731baf4277431028223ee7b4f3517fdfa799e9bb1fc
RWSE3ohX2g5d/SWIUPoeVj99O8U/N7KaUDWQ/NU8N112T+EQ4wlNxYCcf9iQnblkl1/uc35aPg3omGKUaURRpzNHm2Wa09xjugA=
SHA256 (Pkgfile) = b32340745e8e58d7876b302be786e1b01025a96ee7a17cacdc500afcfc829648
SHA256 (.footprint) = aa85bfc686cf873efffd292c55eae8016e161bd8074d4f3490539f6089eead23
SHA256 (ccache-4.5.1.tar.xz) = 51186ebe0326365f4e6131e1caa8911de7da4aa6718efc00680322d63a759517
SHA256 (ccache.1) = 28c9779ef67b746ba3db355fa01f086470f3478248d17bfef453a7ce72e97207

View File

@ -1,8 +1,8 @@
# Description: A fast compiler cache.
# URL: https://ccache.dev/
# Maintainer: Danny Rawlins, crux at romster dot me
# Depends on: cmake
# Optional: clang-ccache-bindings asciidoctor
# Depends on:
# Optional: asciidoctor clang-ccache-bindings
name=ccache
version=4.5.1
@ -11,9 +11,7 @@ source=(https://github.com/$name/$name/releases/download/v$version/$name-$versio
ccache.1)
build() {
[[ -e '/usr/bin/ninja' ]] && PKGMK_CCACHE+=' -G Ninja'
cmake -S $name-$version -B build $PKGMK_CCACHE \
cmake -S $name-$version -B build -G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_INSTALL_LIBDIR=lib \
-D CMAKE_BUILD_TYPE=Release \

View File

@ -1,28 +0,0 @@
diff -pruN ccache-4.0.orig/doc/CMakeLists.txt ccache-4.0/doc/CMakeLists.txt
--- ccache-4.0.orig/doc/CMakeLists.txt 2020-10-28 22:26:27.770955558 +1100
+++ ccache-4.0/doc/CMakeLists.txt 2020-10-28 22:29:16.092274569 +1100
@@ -58,7 +58,11 @@ else()
COMMAND a2x --doctype manpage --format manpage MANUAL.xml
MAIN_DEPENDENCY MANUAL.xml
)
- add_custom_target(doc-man-page DEPENDS ccache.1)
+ add_custom_target(doc-man-page ALL DEPENDS ccache.1)
+ install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/ccache.1"
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
+ )
set(doc_files "${doc_files}" ccache.1)
endif()
diff -pruN ccache-4.0.orig/doc/MANUAL.adoc ccache-4.0/doc/MANUAL.adoc
--- ccache-4.0.orig/doc/MANUAL.adoc 2020-10-28 22:26:27.770955558 +1100
+++ ccache-4.0/doc/MANUAL.adoc 2020-10-28 22:30:10.304959158 +1100
@@ -8,7 +8,7 @@ CCACHE(1)
Name
----
-Ccache - a fast C/C++ compiler cache
+ccache - a fast C/C++ compiler cache
Synopsis