thunderbird: updated to 45.2.0

This commit is contained in:
Fredrik Rinnestam 2016-07-01 21:45:55 +02:00
parent b2b48d7c87
commit d9a7c99a35
3 changed files with 45 additions and 4 deletions

View File

@ -1,3 +1,4 @@
19e1a8eb1aa99927c35ea2fcfbd7f255 thunderbird-45.1.1.source.tar.xz
e46b0d17809d52e6be479a1b77b6445c thunderbird-45.2.0.source.tar.xz
6e75d01fea2602a9fc33028dc3441cfa thunderbird-gcc6.patch
9a78c5c35311cc20425913c5598bf2b9 thunderbird-install-dir.patch
87f8666f06ba8c3668e39068050bb77a thunderbird.desktop

View File

@ -4,15 +4,16 @@
# Depends on: python,gtk,alsa-lib,xorg-libxt,libidl,nss,yasm,mesa3d,libjpeg-turbo
name=thunderbird
version=45.1.1
version=45.2.0
release=1
source=(http://ftp.mozilla.org/pub/thunderbird/releases/$version/source/$name-$version.source.tar.xz
$name.desktop thunderbird-install-dir.patch)
$name.desktop thunderbird-install-dir.patch thunderbird-gcc6.patch)
build() {
cd $name-$version
sed -i '/^ftglyph.h/ i freetype/ftfntfmt.h' mozilla/config/system-headers
patch -p1 -i $SRC/thunderbird-install-dir.patch
patch -p1 -i $SRC/thunderbird-gcc6.patch
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$name"
cat <<- EOF > .mozconfig
@ -29,7 +30,7 @@ cat <<- EOF > .mozconfig
ac_add_options --enable-system-ffi
ac_add_options --enable-system-pixman
#ac_add_options --enable-system-sqlite
#ac_add_options --enable-system-cairo
ac_add_options --enable-system-cairo
ac_add_options --with-pthreads
ac_add_options --enable-optimize="$CFLAGS"
ac_add_options --enable-official-branding
@ -51,6 +52,7 @@ cat <<- EOF > .mozconfig
ac_add_options --disable-pulseaudio
ac_add_options --with-distribution-id=nu.crux
ac_add_options --disable-gconf
ac_add_options --disable-elf-hack
EOF
make -f client.mk build
make -f client.mk DESTDIR=$PKG install

View File

@ -0,0 +1,38 @@
diff -rupN thunderbird-45.1.1.orig/mozilla/config/gcc-stl-wrapper.template.h thunderbird-45.1.1/mozilla/config/gcc-stl-wrapper.template.h
--- thunderbird-45.1.1.orig/mozilla/config/gcc-stl-wrapper.template.h 2016-05-26 23:13:30.000000000 +0200
+++ thunderbird-45.1.1/mozilla/config/gcc-stl-wrapper.template.h 2016-06-07 20:18:28.039462493 +0200
@@ -17,6 +17,11 @@
// Silence "warning: #include_next is a GCC extension"
#pragma GCC system_header
+// Don't include mozalloc for cstdlib. See bug 1245076.
+#ifndef moz_dont_include_mozalloc_for_cstdlib
+# define moz_dont_include_mozalloc_for_cstdlib
+#endif
+#ifndef moz_dont_include_mozalloc_for_${HEADER}
// mozalloc.h wants <new>; break the cycle by always explicitly
// including <new> here. NB: this is a tad sneaky. Sez the gcc docs:
//
@@ -25,15 +30,17 @@
// same name as the current file. It simply looks for the file
// named, starting with the directory in the search path after the
// one where the current file was found.
-#include_next <new>
+# include_next <new>
// See if we're in code that can use mozalloc. NB: this duplicates
// code in nscore.h because nscore.h pulls in prtypes.h, and chromium
// can't build with that being included before base/basictypes.h.
-#if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
-# include "mozilla/mozalloc.h"
-#else
-# error "STL code can only be used with infallible ::operator new()"
+# if !defined(XPCOM_GLUE) && !defined(NS_NO_XPCOM) && !defined(MOZ_NO_MOZALLOC)
+# include "mozilla/mozalloc.h"
+# else
+# error "STL code can only be used with infallible ::operator new()"
+# endif
+
#endif
#if defined(DEBUG) && !defined(_GLIBCXX_DEBUG)