[notify] firefox: updated to 27.0
See https://www.mozilla.org/security/known-vulnerabilities/firefox.html
This commit is contained in:
parent
26e54a7f05
commit
eea4f47a60
2914
firefox/.footprint
2914
firefox/.footprint
File diff suppressed because it is too large
Load Diff
@ -1,2 +1,3 @@
|
||||
91ce51cc6474f1269484e5327643a59c firefox-26.0.source.tar.bz2
|
||||
212827908144b43e7c80ed9d56a08ca9 firefox-27.0.source.tar.bz2
|
||||
1a889dca3c685e97b5f577a558360bd2 firefox-install-dir.patch
|
||||
cf6971669f70b440cb6ff8df8b2722ae firefox.desktop
|
||||
|
@ -2,22 +2,19 @@
|
||||
# URL: http://www.mozilla.com/firefox/
|
||||
# Maintainer: Fredrik Rinnestam, fredrik at crux dot nu
|
||||
# Depends on: nss, libidl, gtk, python, alsa-lib, yasm, mesa3d
|
||||
|
||||
|
||||
name=firefox
|
||||
version=26.0
|
||||
version=27.0
|
||||
release=1
|
||||
source=(ftp://ftp.mozilla.org/pub/firefox/releases/$version/source/firefox-$version.source.tar.bz2
|
||||
firefox.desktop)
|
||||
|
||||
firefox-install-dir.patch firefox.desktop)
|
||||
|
||||
build() {
|
||||
export MOZ_CO_PROJECT=browser
|
||||
export BUILD_OFFICIAL=1
|
||||
export MOZILLA_OFFICIAL=1
|
||||
export MOZILLA_FIVE_HOME=/usr/lib/firefox
|
||||
|
||||
cd mozilla-release
|
||||
|
||||
cat <<- EOF > .mozconfig
|
||||
|
||||
patch -p 1 -i $SRC/firefox-install-dir.patch
|
||||
|
||||
cat <<- EOF > .mozconfig
|
||||
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox-shared
|
||||
mk_add_options MOZ_MAKE_FLAGS="$MAKEFLAGS -s"
|
||||
ac_add_options --prefix=/usr
|
||||
@ -62,30 +59,13 @@ build() {
|
||||
ac_add_options --disable-libnotify
|
||||
ac_add_options --disable-gstreamer
|
||||
EOF
|
||||
mkdir $SRC/mozilla-release/js/src/.deps
|
||||
|
||||
./configure
|
||||
make
|
||||
install -d \
|
||||
$PKG$MOZILLA_FIVE_HOME \
|
||||
$PKG/usr/bin \
|
||||
$PKG/usr/share/idl/firefox \
|
||||
$PKG/usr/include/firefox
|
||||
|
||||
cp -rL dist/bin/* $PKG$MOZILLA_FIVE_HOME
|
||||
ln -s /usr/lib/firefox/firefox $PKG/usr/bin/firefox
|
||||
|
||||
# devel stuff
|
||||
cp -frL dist/idl/* $PKG/usr/share/idl/firefox/
|
||||
cp -frL dist/include/* $PKG/usr/include/firefox/
|
||||
|
||||
make -f client.mk build
|
||||
make -f client.mk DESTDIR=$PKG install
|
||||
|
||||
install -d $PKG/etc/ld.so.conf.d
|
||||
echo "/usr/lib/$name" > $PKG/etc/ld.so.conf.d/$name.conf
|
||||
echo "/usr/lib/firefox" > $PKG/etc/ld.so.conf.d/$name.conf
|
||||
|
||||
# cleanup
|
||||
find $PKG -type f -empty -delete
|
||||
|
||||
# desktop stuff
|
||||
mkdir -p $PKG/usr/share/pixmaps
|
||||
ln -s /usr/lib/firefox/browser/chrome/browser/content/branding/icon48.png $PKG/usr/share/pixmaps/firefox_default48.png
|
||||
install -D -m 0644 $SRC/firefox.desktop $PKG/usr/share/applications/firefox.desktop
|
||||
|
26
firefox/firefox-install-dir.patch
Normal file
26
firefox/firefox-install-dir.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -Nur mozilla-beta.orig/config/baseconfig.mk mozilla-beta/config/baseconfig.mk
|
||||
--- mozilla-beta.orig/config/baseconfig.mk 2014-01-14 20:37:43.142280922 +0100
|
||||
+++ mozilla-beta/config/baseconfig.mk 2014-01-14 20:38:40.184259453 +0100
|
||||
@@ -1,7 +1,7 @@
|
||||
-includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
+includedir := $(includedir)/$(MOZ_APP_NAME)
|
||||
+idldir = $(datadir)/idl/$(MOZ_APP_NAME)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
|
||||
DIST = $(DEPTH)/dist
|
||||
|
||||
# We do magic with OBJ_SUFFIX in config.mk, the following ensures we don't
|
||||
diff -Nur mozilla-beta.orig/js/src/config/baseconfig.mk mozilla-beta/js/src/config/baseconfig.mk
|
||||
--- mozilla-beta.orig/js/src/config/baseconfig.mk 2014-01-14 20:37:43.732301391 +0100
|
||||
+++ mozilla-beta/js/src/config/baseconfig.mk 2014-01-14 20:39:12.769389327 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
|
||||
-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
|
||||
+installdir = $(libdir)/$(MOZ_APP_NAME)
|
||||
+sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel
|
||||
|
||||
ifneq (,$(filter /%,$(TOP_DIST)))
|
||||
DIST = $(TOP_DIST)
|
Loading…
x
Reference in New Issue
Block a user