grub: Fixed compilation issue with automake 1.11.3

This commit is contained in:
Alan Mizrahi 2012-02-27 10:37:17 +09:00
parent 838fe54104
commit f25f3b4d78
3 changed files with 48 additions and 1 deletions

View File

@ -1,3 +1,4 @@
2d2d7927c1dca07ca1eb0ca151ce304c automake.patch
571ab75bb9f4c247853d93264eda1df4 crux02.xpm.gz
55e343038043e16df5293d63782373d0 crux03.xpm.gz
39e0f9a05b7e04aceb24fc7bc4893e3d ext4.patch

View File

@ -6,10 +6,11 @@
name=grub
version=0.97
release=6
release=7
source=(ftp://alpha.gnu.org/gnu/grub/$name-$version.tar.gz \
http://crux.nu/files/grub/0.97/$name-$version-patches-2.tar.bz2 \
ext4.patch \
automake.patch \
http://crux.nu/files/grub/common/crux02.xpm.gz \
http://crux.nu/files/grub/common/crux03.xpm.gz \
menu.lst.sample)

45
grub/automake.patch Normal file
View File

@ -0,0 +1,45 @@
--- grub-0.97/stage1/Makefile.am.orig 2012-02-27 10:28:38.000000000 +0900
+++ grub-0.97/stage1/Makefile.am 2012-02-27 10:29:32.000000000 +0900
@@ -1,5 +1,5 @@
-pkglibdir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
-nodist_pkglib_DATA = stage1
+stagedir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
+nodist_stage_DATA = stage1
CLEANFILES = $(nodist_pkglib_DATA)
--- grub-0.97/stage2/Makefile.am.orig 2012-02-27 10:29:39.000000000 +0900
+++ grub-0.97/stage2/Makefile.am 2012-02-27 10:30:37.000000000 +0900
@@ -27,12 +27,12 @@
-DUSE_MD5_PASSWORDS=1 -DSUPPORT_SERIAL=1 -DSUPPORT_HERCULES=1
# Stage 2 and Stage 1.5's.
-pkglibdir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
+stagedir = $(libdir)/$(PACKAGE)/$(host_cpu)-$(host_vendor)
EXTRA_PROGRAMS = nbloader.exec pxeloader.exec diskless.exec
if DISKLESS_SUPPORT
-pkglib_DATA = stage2 stage2_eltorito e2fs_stage1_5 fat_stage1_5 \
+stage_DATA = stage2 stage2_eltorito e2fs_stage1_5 fat_stage1_5 \
ffs_stage1_5 iso9660_stage1_5 jfs_stage1_5 minix_stage1_5 \
reiserfs_stage1_5 ufs2_stage1_5 vstafs_stage1_5 xfs_stage1_5 \
nbgrub pxegrub
@@ -43,7 +43,7 @@
reiserfs_stage1_5.exec ufs2_stage1_5.exec vstafs_stage1_5.exec \
xfs_stage1_5.exec nbloader.exec pxeloader.exec diskless.exec
else
-pkglib_DATA = stage2 stage2_eltorito e2fs_stage1_5 fat_stage1_5 \
+stage_DATA = stage2 stage2_eltorito e2fs_stage1_5 fat_stage1_5 \
ffs_stage1_5 iso9660_stage1_5 jfs_stage1_5 minix_stage1_5 \
reiserfs_stage1_5 ufs2_stage1_5 vstafs_stage1_5 xfs_stage1_5
noinst_DATA = pre_stage2 start start_eltorito
@@ -112,7 +112,7 @@
BUILT_SOURCES = stage2_size.h
endif
-CLEANFILES = $(pkglib_DATA) $(noinst_DATA) $(BUILT_SOURCES)
+CLEANFILES = $(stage_DATA) $(noinst_DATA) $(BUILT_SOURCES)
stage2_size.h: pre_stage2
-rm -f stage2_size.h