mysql: update to 5.1.49

This commit is contained in:
Juergen Daubert 2010-07-23 11:46:54 +02:00
parent 93a6559637
commit f54d1e1ddd
3 changed files with 47 additions and 29 deletions

View File

@ -1,4 +1,4 @@
907c4ac28c33b2508750bca8a29ef9b9 my.cnf 907c4ac28c33b2508750bca8a29ef9b9 my.cnf
a2ffcadadfd8b2cda80f3dddbc8933fe mysql-5.1-gcc45-apicheck.patch fda6e1139f11cc501ca600070424caa8 mysql-5.1-gcc45-apicheck.patch
d04c54d1cfbd8c6c8650c8d078f885b2 mysql-5.1.48.tar.gz a90d87a71fa3c23dff6d78afc8e3184c mysql-5.1.49.tar.gz
642a596f13ebd7e459c5ff2fd382f06b mysqld 642a596f13ebd7e459c5ff2fd382f06b mysqld

View File

@ -4,7 +4,7 @@
# Depends on: ncurses readline zlib # Depends on: ncurses readline zlib
name=mysql name=mysql
version=5.1.48 version=5.1.49
release=1 release=1
source=(http://mirror.switch.ch/mirror/mysql/Downloads/MySQL-5.1/$name-$version.tar.gz \ source=(http://mirror.switch.ch/mirror/mysql/Downloads/MySQL-5.1/$name-$version.tar.gz \
my.cnf mysqld mysql-5.1-gcc45-apicheck.patch) my.cnf mysqld mysql-5.1-gcc45-apicheck.patch)

View File

@ -1,31 +1,49 @@
# http://bugs.mysql.com/bug.php?id=52514 # http://bugs.mysql.com/bug.php?id=52514
diff -Nru mysql-5.1.47.orig/Makefile.in mysql-5.1.47/Makefile.in diff -Nru mysql-5.1.49.orig/Makefile.in mysql-5.1.49/Makefile.in
--- mysql-5.1.47.orig/Makefile.in 2010-05-25 21:39:20.411815787 +0200 --- mysql-5.1.49.orig/Makefile.in 2010-07-23 11:19:04.883436681 +0200
+++ mysql-5.1.47/Makefile.in 2010-05-25 21:40:35.201822062 +0200 +++ mysql-5.1.49/Makefile.in 2010-07-23 11:24:08.673443229 +0200
@@ -1132,24 +1132,7 @@ @@ -1097,9 +1097,10 @@
$(MAKE) abi_headers="$^" do_abi_check # 1) Generate preprocessor output for the files that need to
# be tested for abi/api changes. use -nostdinc to prevent
# generation of preprocessor output for system headers. This
-# results in messages in stderr saying that these headers
-# were not found. Redirect the stderr output to /dev/null
-# to prevent seeing these messages.
+# results in messages in stderr saying that these headers were not found
+# with older gccs and in an error with newer ones. Redirect the stderr
+# output to /dev/null to prevent seeing these messages, and guard includes
+# with #ifndef mysql_abi_check; define mysql_abi_check for the abi check.
# 2) sed the output to
# 2.1) remove blank lines and lines that begin with "# "
# 2.2) When gcc -E is run on the Mac OS and solaris sparc platforms it
@@ -1135,7 +1136,7 @@
do_abi_check: do_abi_check:
- set -ex; \ set -ex; \
- for file in $(abi_headers); do \ for file in $(abi_headers); do \
- @CC@ -E -nostdinc -dI \ - @CC@ -E -nostdinc -dI \
- -I$(top_srcdir)/include \ + @CC@ -Dmysql_abi_check -E -nostdinc -dI \
- -I$(top_srcdir)/include/mysql \ -I$(top_srcdir)/include \
- -I$(top_srcdir)/sql \ -I$(top_srcdir)/include/mysql \
- -I$(top_builddir)/include \ -I$(top_srcdir)/sql \
- -I$(top_builddir)/include/mysql \ diff -Nru mysql-5.1.49.orig/include/mysql.h mysql-5.1.49/include/mysql.h
- -I$(top_builddir)/sql \ --- mysql-5.1.49.orig/include/mysql.h 2010-07-23 11:19:05.353433926 +0200
- $$file 2>/dev/null | \ +++ mysql-5.1.49/include/mysql.h 2010-07-23 11:24:08.673443229 +0200
- @SED@ -e '/^# /d' \ @@ -44,7 +44,9 @@
- -e '/^[ ]*$$/d' \ #endif
- -e '/^#pragma GCC set_debug_pwd/d' \
- -e '/^#ident/d' > \
- $(top_builddir)/abi_check.out; \
- @DIFF@ -w $$file.pp $(top_builddir)/abi_check.out; \
- @RM@ $(top_builddir)/abi_check.out; \
- done
+ echo "Skipping do_abi_check"
# Don't update the files from bitkeeper #ifndef _global_h /* If not standard header */
%::SCCS/s.% +#ifndef mysql_abi_check
#include <sys/types.h>
+#endif
#ifdef __LCC__
#include <winsock2.h> /* For windows */
#endif
diff -Nru mysql-5.1.49.orig/include/mysql.h.pp mysql-5.1.49/include/mysql.h.pp
--- mysql-5.1.49.orig/include/mysql.h.pp 2010-07-23 11:19:05.353433926 +0200
+++ mysql-5.1.49/include/mysql.h.pp 2010-07-23 11:24:08.673443229 +0200
@@ -1,4 +1,3 @@
-#include <sys/types.h>
typedef char my_bool;
typedef int my_socket;
#include "mysql_version.h"