47 lines
2.0 KiB
Diff
47 lines
2.0 KiB
Diff
diff -Nru spectrwm-2.6.0.orig/linux/Makefile spectrwm-2.6.0/linux/Makefile
|
|
--- spectrwm-2.6.0.orig/linux/Makefile 2014-08-23 09:01:02.136856255 +0200
|
|
+++ spectrwm-2.6.0/linux/Makefile 2014-08-23 09:02:22.330669060 +0200
|
|
@@ -10,7 +10,7 @@
|
|
LIBMAJORVERSION = $(shell . $(CURDIR)/../lib/shlib_version; echo $$major)
|
|
|
|
MAINT_CFLAGS = -std=c99 -Wmissing-prototypes -Wall -Wextra -Wshadow -Wno-uninitialized -g
|
|
-MAINT_CPPFLAGS = -D_GNU_SOURCE -I. -I/usr/include/freetype2 -DSWM_LIB=\"$(LIBDIR)/libswmhack.so.$(LIBVERSION)\"
|
|
+MAINT_CPPFLAGS = -D_GNU_SOURCE -I. -I/usr/include/freetype2
|
|
MAINT_LDLIBS = -lX11 -lX11-xcb -lxcb -lxcb-icccm -lxcb-randr -lxcb-keysyms -lxcb-util -lxcb-xtest -lXft -lXcursor
|
|
|
|
ifneq ("${BUILDVERSION}", "")
|
|
@@ -48,9 +48,6 @@
|
|
install -m 755 -d $(DESTDIR)$(XSESSIONSDIR)
|
|
install -m 755 spectrwm $(DESTDIR)$(BINDIR)
|
|
ln -sf spectrwm $(DESTDIR)$(BINDIR)/scrotwm
|
|
- install -m 644 libswmhack.so.$(LIBVERSION) $(DESTDIR)$(LIBDIR)
|
|
- ln -sf libswmhack.so.$(LIBVERSION) $(DESTDIR)$(LIBDIR)/libswmhack.so.$(LIBMAJORVERSION)
|
|
- ln -sf libswmhack.so.$(LIBVERSION) $(DESTDIR)$(LIBDIR)/libswmhack.so
|
|
install -m 644 ../spectrwm.1 $(DESTDIR)$(MANDIR)/man1/spectrwm.1
|
|
install -m 644 ../spectrwm_es.1 $(DESTDIR)$(MANDIR)/es/man1/spectrwm.1
|
|
install -m 644 ../spectrwm_it.1 $(DESTDIR)$(MANDIR)/it/man1/spectrwm.1
|
|
diff -Nru spectrwm-2.6.0.orig/spectrwm.c spectrwm-2.6.0/spectrwm.c
|
|
--- spectrwm-2.6.0.orig/spectrwm.c 2014-08-23 09:01:02.136856255 +0200
|
|
+++ spectrwm-2.6.0/spectrwm.c 2014-08-23 09:04:35.139391508 +0200
|
|
@@ -300,9 +300,9 @@
|
|
#define SWM_CONF_DEFAULT (0)
|
|
#define SWM_CONF_KEYMAPPING (1)
|
|
|
|
-#ifndef SWM_LIB
|
|
+/* #ifndef SWM_LIB
|
|
#define SWM_LIB "/usr/local/lib/libswmhack.so"
|
|
-#endif
|
|
+#endif */
|
|
|
|
char **start_argv;
|
|
xcb_atom_t a_state;
|
|
@@ -3349,7 +3349,7 @@
|
|
|
|
close(xcb_get_file_descriptor(conn));
|
|
|
|
- setenv("LD_PRELOAD", SWM_LIB, 1);
|
|
+ /* setenv("LD_PRELOAD", SWM_LIB, 1); */
|
|
|
|
if (asprintf(&ret, "%d", ws_idx) == -1) {
|
|
warn("spawn: asprintf SWM_WS");
|