opt/cairo/xlib-xcb.diff
Juergen Daubert 70cdf5f84a [notify] cairo: update to 1.17.4
Note:
-----
build system switched from autotools to meson, therefore
all libtool files (*.la) are gone.
Every port that lists the old libcairo.la file in its own
libtool file has to be rebuild if other ports depends at
build time on it.

To find the broken files the following script can be usesd:

  for f in $(grep -lrs libcairo.la /usr/lib/); do \
    pkginfo -o $f | awk '!/^Package/ {print $1}'; \
  done | sort -u
2021-01-03 13:04:53 +01:00

26 lines
1.0 KiB
Diff

diff --git i/meson.build w/meson.build
index b159b4071..2a1c68891 100644
--- i/meson.build
+++ w/meson.build
@@ -313,7 +313,7 @@ endif
if feature_conf.get('CAIRO_HAS_XCB_SURFACE', 0) == 1 and feature_conf.get('CAIRO_HAS_XLIB_SURFACE', 0) == 1
# FIXME: automagic
- x11xcb_dep = dependency('x11-xcb', required: false)
+ x11xcb_dep = dependency('x11-xcb', required: get_option('xlib-xcb'))
if x11xcb_dep.found()
deps += [x11xcb_dep]
feature_conf.set('CAIRO_HAS_XLIB_XCB_FUNCTIONS', 1)
diff --git i/meson_options.txt w/meson_options.txt
index ff11fe7ed..d1ae959e1 100644
--- i/meson_options.txt
+++ w/meson_options.txt
@@ -17,6 +17,7 @@ option('qt', type : 'feature', value : 'disabled')
option('tee', type : 'feature', value : 'disabled')
option('xcb', type : 'feature', value : 'auto')
option('xlib', type : 'feature', value : 'auto')
+option('xlib-xcb', type : 'feature', value : 'disabled')
#option('xml', type : 'feature', value : 'disabled')
option('zlib', type : 'feature', value : 'auto') # script, ps, pdf, xml surfaces