opt/lvm2/lvm2-static_udev_rt.patch
Michal Soltys 706b21c2c4 opt/lvm2: update to use udev
This delegates node creation to udev. Among other things, the
important advantage of this approach is population of all the related
stuff in /dev/disk/by-* ; relying on udev can also be controlled
through lvm.conf and some commands' options.

Comments related to this version:

- another minor patch for static build scenario had to be applied;
  hopefully it will be fixed in upstream one day

- configure is now consistent with libdevmapper (they can be trivially
  merged into single package now)

- if you ran vgchange initially without udevd active (e.g. in
  initramfs), you will likely need vgchange --refresh (vgmknodes
  --refresh could work too, not tested though); this is important if you
  expect /dev/disk/by-* to be filled with lvm stuff after handover from
  udevless initramfs (fstab, mount, etc.).

Signed-off-by: Michal Soltys <soltys@ziu.info>
2011-03-16 09:38:02 +01:00

25 lines
1.2 KiB
Diff

diff -ur LVM2.2.02.84.orig/configure LVM2.2.02.84/configure
--- LVM2.2.02.84.orig/configure 2011-02-17 13:52:46.028748001 +0100
+++ LVM2.2.02.84/configure 2011-02-19 23:40:55.753991226 +0100
@@ -8799,7 +8799,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_udev_udev_queue_get_udev_is_active" >&5
$as_echo "$ac_cv_lib_udev_udev_queue_get_udev_is_active" >&6; }
if test "x$ac_cv_lib_udev_udev_queue_get_udev_is_active" = x""yes; then :
- UDEV_PC="libudev"; UDEV_LIBS="-ludev"
+ UDEV_PC="libudev"; UDEV_LIBS="-ludev -lrt"
else
as_fn_error $? "bailing out... libudev library is required" "$LINENO" 5
fi
diff -ur LVM2.2.02.84.orig/configure.in LVM2.2.02.84/configure.in
--- LVM2.2.02.84.orig/configure.in 2011-02-17 13:52:46.026748001 +0100
+++ LVM2.2.02.84/configure.in 2011-02-19 23:41:42.625996529 +0100
@@ -804,7 +804,7 @@
if test x$UDEV_SYNC = xyes; then
AC_CHECK_LIB(udev, udev_queue_get_udev_is_active,
- [UDEV_PC="libudev"; UDEV_LIBS="-ludev"],
+ [UDEV_PC="libudev"; UDEV_LIBS="-ludev -lrt"],
[AC_MSG_ERROR([bailing out... libudev library is required])])
AC_DEFINE([UDEV_SYNC_SUPPORT], 1, [Define to 1 to enable synchronisation with udev processing.])
fi