opt/xulrunner/xulrunner.diff
2009-07-04 13:08:12 +02:00

102 lines
3.8 KiB
Diff

---
xulrunner/installer/Makefile.in | 15 ++++++++++++---
xulrunner/installer/libxul-embedding-unstable.pc.in | 2 +-
xulrunner/installer/libxul-embedding.pc.in | 2 +-
xulrunner/installer/mozilla-nss.pc.in | 6 +++---
4 files changed, 17 insertions(+), 8 deletions(-)
Index: mozilla/xulrunner/installer/Makefile.in
===================================================================
--- mozilla.orig/xulrunner/installer/Makefile.in
+++ mozilla/xulrunner/installer/Makefile.in
@@ -91,29 +91,38 @@
mozilla-plugin.pc \
mozilla-gtkmozembed.pc \
mozilla-gtkmozembed-embedding.pc \
$(NULL)
ifdef MOZ_NATIVE_NSPR
NSPR_NAME=nspr
NSPR_VERSION=$(shell $(NSPR_CONFIG) --version)
+FULL_NSPR_CFLAGS=$(shell $(NSPR_CONFIG) --cflags)
+FULL_NSPR_LIBS=$(shell $(NSPR_CONFIG) --libs)
else
-pkg_config_files += mozilla-nspr.pc
NSPR_NAME=mozilla-nspr
FULL_NSPR_CFLAGS=-I\$${includedir}/stable
FULL_NSPR_LIBS=$(subst $(prefix),\$${sdkdir},$(shell $(DEPTH)/nsprpub/config/nspr-config --libs))
NSPR_VERSION=$(shell $(DEPTH)/nsprpub/config/nspr-config --version)
endif
+pkg_config_files += mozilla-nspr.pc
$(warning FULL_NSPR_CFLAGS=$(FULL_NSPR_CFLAGS))
-ifndef MOZ_NATIVE_NSS
-pkg_config_files += mozilla-nss.pc
+ifdef MOZ_NATIVE_NSS
+NSPR_VERSION=$(shell $(NSS_CONFIG) --version)
+FULL_NSS_CFLAGS=$(shell $(NSS_CONFIG) --cflags)
+FULL_NSS_LIBS=$(shell $(NSS_CONFIG) --libs)
+else
+NSS_VERSION=$(shell $(DEPTH)/nsprpub/config/nss-config --version)
+FULL_NSS_CFLAGS=-I\$${includedir}/stable
+FULL_NSS_LIBS=$(subst $(prefix),\$${sdkdir},$(shell $(DEPTH)/nsprpub/config/nss-config --libs))
endif
+pkg_config_files += mozilla-nss.pc
ifdef MOZ_OJI
OJIDEF=-DOJI
else
OJIDEF=
endif
%.pc: $(srcdir)/%.pc.in $(GLOBAL_DEPS)
Index: mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in
===================================================================
--- mozilla.orig/xulrunner/installer/libxul-embedding-unstable.pc.in
+++ mozilla/xulrunner/installer/libxul-embedding-unstable.pc.in
@@ -3,9 +3,9 @@
includedir=%includedir%
idldir=%idldir%
includetype=unstable
Name: libxul-embedding-unstable
Description: Static library for version-independent embedding of the Mozilla runtime (unstable API)
Version: %MOZILLA_VERSION%
Libs: -L${sdkdir}/lib -lxpcomglue
-Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS%
+Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS% %FULL_NSPR_CFLAGS%
Index: mozilla/xulrunner/installer/libxul-embedding.pc.in
===================================================================
--- mozilla.orig/xulrunner/installer/libxul-embedding.pc.in
+++ mozilla/xulrunner/installer/libxul-embedding.pc.in
@@ -7,9 +7,9 @@
# Note: the default pkg-config cflags will only list include directories
# that contain stable (frozen or safe for linking) header files. To include
# nonfrozen headers, run pkg-config with --define-variable=includetype=unstable
Name: libxul-embedding
Description: Static library for version-independent embedding of the Mozilla runtime
Version: %MOZILLA_VERSION%
Libs: -L${sdkdir}/lib -lxpcomglue
-Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS%
+Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS% %FULL_NSPR_CFLAGS%
Index: mozilla/xulrunner/installer/mozilla-nss.pc.in
===================================================================
--- mozilla.orig/xulrunner/installer/mozilla-nss.pc.in
+++ mozilla/xulrunner/installer/mozilla-nss.pc.in
@@ -1,10 +1,10 @@
prefix=%prefix%
sdkdir=%sdkdir%
includedir=%includedir%
Name: NSS
Description: Mozilla Network Security Services
-Version: %MOZILLA_VERSION%
+Version: %NSS_VERSION%
Requires: %NSPR_NAME% >= %NSPR_VERSION%
-Libs: -L${sdkdir}/lib -lnss3 -lnssutil3 -lsmime3 -lssl3 -lsoftokn3
-Cflags: -I${includedir}/stable
+Libs: %FULL_NSS_LIBS%
+Cflags: %FULL_NSS_CFLAGS%