opt/ccache/ccache-man.patch
Danny Rawlins 5743963242 [notify] ccache: 3.7.12 -> 4.0
New dependency cmake
Changed compression algorithm from Deflate (zlib) to Zstandard, zstd will be used if installed, else it'll compile ccache staticly with a local zstd copy
Changed hash algorithm from MD4 to BLAKE3
Improved cache directory structure
Changed the default cache directory location to follow the XDG base directory specification
The CCACHE_DIR environment variable still overrides the default location just like before
The cache directory structure has changed compared to previous versions (more details below). This means that ccache 4.0 will not share cache results with earlier versions. It is however safe to run ccache 4.0 and earlier versions against the same cache directory: cache bookkeeping, statistics and cleanup are backward compatible, with the minor exception that some statistics counters incremented by ccache 4.0 won’t be visible when running ccache -s with an older version
https://ccache.dev/releasenotes.html#_ccache_4_0
2020-10-28 23:07:11 +11:00

29 lines
981 B
Diff

diff -pruN ccache-4.0.orig/doc/CMakeLists.txt ccache-4.0/doc/CMakeLists.txt
--- ccache-4.0.orig/doc/CMakeLists.txt 2020-10-28 22:26:27.770955558 +1100
+++ ccache-4.0/doc/CMakeLists.txt 2020-10-28 22:29:16.092274569 +1100
@@ -58,7 +58,11 @@ else()
COMMAND a2x --doctype manpage --format manpage MANUAL.xml
MAIN_DEPENDENCY MANUAL.xml
)
- add_custom_target(doc-man-page DEPENDS ccache.1)
+ add_custom_target(doc-man-page ALL DEPENDS ccache.1)
+ install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/ccache.1"
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
+ )
set(doc_files "${doc_files}" ccache.1)
endif()
diff -pruN ccache-4.0.orig/doc/MANUAL.adoc ccache-4.0/doc/MANUAL.adoc
--- ccache-4.0.orig/doc/MANUAL.adoc 2020-10-28 22:26:27.770955558 +1100
+++ ccache-4.0/doc/MANUAL.adoc 2020-10-28 22:30:10.304959158 +1100
@@ -8,7 +8,7 @@ CCACHE(1)
Name
----
-Ccache - a fast C/C++ compiler cache
+ccache - a fast C/C++ compiler cache
Synopsis