opt/lua/lua.diff
2007-04-09 21:32:46 +02:00

88 lines
2.6 KiB
Diff

Somewhat based on Arch Linux' Lua patch.
diff -aur lua-5.1.2.orig/Makefile lua-5.1.2/Makefile
--- lua-5.1.2.orig/Makefile 2007-03-25 16:44:39.000000000 +0200
+++ lua-5.1.2/Makefile 2007-04-09 20:22:39.100496674 +0200
@@ -43,7 +43,7 @@
# What to install.
TO_BIN= lua luac
TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp
-TO_LIB= liblua.a
+TO_LIB= liblua.a liblua.so.5.1
TO_MAN= lua.1 luac.1
# Lua version and release.
@@ -65,6 +65,7 @@
cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
# $(RANLIB) $(INSTALL_LIB)/$(TO_LIB)
+ ln -s liblua.so.5.1 $(INSTALL_LIB)/liblua.so
local:
$(MAKE) install INSTALL_TOP=.. INSTALL_EXEC="cp -p" INSTALL_DATA="cp -p"
diff -aur lua-5.1.2.orig/etc/lua.pc lua-5.1.2/etc/lua.pc
--- lua-5.1.2.orig/etc/lua.pc 2007-03-23 20:58:49.000000000 +0100
+++ lua-5.1.2/etc/lua.pc 2007-04-09 20:00:26.642825529 +0200
@@ -8,7 +8,7 @@
R= 5.1.2
# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
-prefix= /usr/local
+prefix= /usr
INSTALL_BIN= ${prefix}/bin
INSTALL_INC= ${prefix}/include
INSTALL_LIB= ${prefix}/lib
diff -aur lua-5.1.2.orig/src/Makefile lua-5.1.2/src/Makefile
--- lua-5.1.2.orig/src/Makefile 2007-03-25 16:49:23.000000000 +0200
+++ lua-5.1.2/src/Makefile 2007-04-09 20:20:37.073542755 +0200
@@ -8,7 +8,8 @@
PLAT= none
CC= gcc
-CFLAGS= -O2 -Wall $(MYCFLAGS)
+CFLAGS ?= -O2 -Wall
+CFLAGS += $(MYCFLAGS)
AR= ar rcu
RANLIB= ranlib
RM= rm -f
@@ -23,6 +24,7 @@
PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
LUA_A= liblua.a
+LUA_SO= liblua.so
CORE_O= lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o \
lundump.o lvm.o lzio.o
@@ -36,7 +38,7 @@
LUAC_O= luac.o print.o
ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O)
-ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
ALL_A= $(LUA_A)
default: $(PLAT)
@@ -51,6 +53,10 @@
$(AR) $@ $?
$(RANLIB) $@
+$(LUA_SO): $(CORE_O) $(LIB_O)
+ $(CC) -shared -Wl,-soname,liblua.so -o $@.5.1 $? $(MYLDFLAGS)
+ ln -s $@.5.1 $@
+
$(LUA_T): $(LUA_O) $(LUA_A)
$(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
diff -aur lua-5.1.2.orig/src/luaconf.h lua-5.1.2/src/luaconf.h
--- lua-5.1.2.orig/src/luaconf.h 2007-03-24 04:01:55.000000000 +0100
+++ lua-5.1.2/src/luaconf.h 2007-04-09 20:01:00.274480800 +0200
@@ -94,7 +94,7 @@
".\\?.dll;" LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
#else
-#define LUA_ROOT "/usr/local/"
+#define LUA_ROOT "/usr/"
#define LUA_LDIR LUA_ROOT "share/lua/5.1/"
#define LUA_CDIR LUA_ROOT "lib/lua/5.1/"
#define LUA_PATH_DEFAULT \