opt/dnsmasq/dnsmasq-config.patch

57 lines
2.1 KiB
Diff

diff -Nru dnsmasq-2.77.orig/Makefile dnsmasq-2.77/Makefile
--- dnsmasq-2.77.orig/Makefile 2017-06-02 15:14:52.782042400 +0200
+++ dnsmasq-2.77/Makefile 2017-06-02 15:15:07.138204285 +0200
@@ -24,7 +24,7 @@
LOCALEDIR = $(PREFIX)/share/locale
BUILDDIR = $(SRC)
DESTDIR =
-CFLAGS = -Wall -W -O2
+CFLAGS += -Wall -W
LDFLAGS =
COPTS =
RPM_OPT_FLAGS =
diff -Nru dnsmasq-2.77.orig/dnsmasq.conf.example dnsmasq-2.77/dnsmasq.conf.example
--- dnsmasq-2.77.orig/dnsmasq.conf.example 2017-06-02 15:14:52.782042400 +0200
+++ dnsmasq-2.77/dnsmasq.conf.example 2017-06-02 15:15:07.138204285 +0200
@@ -96,8 +96,8 @@
# If you want dnsmasq to change uid and gid to something other
# than the default, edit the following lines.
-#user=
-#group=
+#user=nobody
+#group=nobody
# If you want dnsmasq to listen for DHCP and DNS requests only on
# specified interfaces (and the loopback) give the name of the
@@ -535,7 +535,7 @@
# The DHCP server needs somewhere on disk to keep its lease database.
# This defaults to a sane location, but if you want to change it, use
# the line below.
-#dhcp-leasefile=/var/lib/misc/dnsmasq.leases
+# dhcp-leasefile=/var/lib/dhcp/dnsmasq.leases
# Set the DHCP server to authoritative mode. In this mode it will barge in
# and take over the lease for any client which broadcasts on the network,
diff -Nru dnsmasq-2.77.orig/src/config.h dnsmasq-2.77/src/config.h
--- dnsmasq-2.77.orig/src/config.h 2017-06-02 15:14:52.778709183 +0200
+++ dnsmasq-2.77/src/config.h 2017-06-02 15:15:07.138204285 +0200
@@ -43,7 +43,7 @@
#define ETHERSFILE "/etc/ethers"
#define DEFLEASE 3600 /* default lease time, 1 hour */
#define CHUSER "nobody"
-#define CHGRP "dip"
+#define CHGRP "nobody"
#define TFTP_MAX_CONNECTIONS 50 /* max simultaneous connections */
#define LOG_MAX 5 /* log-queue length */
#define RANDFILE "/dev/urandom"
@@ -192,7 +192,7 @@
# elif defined(__ANDROID__)
# define LEASEFILE "/data/misc/dhcp/dnsmasq.leases"
# else
-# define LEASEFILE "/var/lib/misc/dnsmasq.leases"
+# define LEASEFILE "/var/lib/dhcp/dnsmasq.leases"
# endif
#endif