opt/vsftpd/vsftpd-2.0.4.patch
2006-02-23 15:26:10 +00:00

124 lines
4.5 KiB
Diff

diff -Nru vsftpd-2.0.4.orig/Makefile vsftpd-2.0.4/Makefile
--- vsftpd-2.0.4.orig/Makefile 2006-01-10 19:25:18.000000000 +0100
+++ vsftpd-2.0.4/Makefile 2006-01-10 19:25:36.000000000 +0100
@@ -3,7 +3,7 @@
INSTALL = install
IFLAGS = -idirafter dummyinc
#CFLAGS = -g
-CFLAGS = -O2 -Wall -W -Wshadow #-pedantic -Werror -Wconversion
+CFLAGS += -Wall -W -Wshadow #-pedantic -Werror -Wconversion
LIBS = `./vsf_findlibs.sh`
LINK = -Wl,-s
@@ -24,21 +24,10 @@
$(CC) -o vsftpd $(OBJS) $(LINK) $(LIBS) $(LDFLAGS)
install:
- if [ -x /usr/local/sbin ]; then \
- $(INSTALL) -m 755 vsftpd /usr/local/sbin/vsftpd; \
- else \
- $(INSTALL) -m 755 vsftpd /usr/sbin/vsftpd; fi
- if [ -x /usr/local/man ]; then \
- $(INSTALL) -m 644 vsftpd.8 /usr/local/man/man8/vsftpd.8; \
- $(INSTALL) -m 644 vsftpd.conf.5 /usr/local/man/man5/vsftpd.conf.5; \
- elif [ -x /usr/share/man ]; then \
- $(INSTALL) -m 644 vsftpd.8 /usr/share/man/man8/vsftpd.8; \
- $(INSTALL) -m 644 vsftpd.conf.5 /usr/share/man/man5/vsftpd.conf.5; \
- else \
- $(INSTALL) -m 644 vsftpd.8 /usr/man/man8/vsftpd.8; \
- $(INSTALL) -m 644 vsftpd.conf.5 /usr/man/man5/vsftpd.conf.5; fi
- if [ -x /etc/xinetd.d ]; then \
- $(INSTALL) -m 644 xinetd.d/vsftpd /etc/xinetd.d/vsftpd; fi
+ $(INSTALL) -D -m 755 vsftpd $(DESTDIR)/usr/sbin/vsftpd
+ $(INSTALL) -D -m 644 vsftpd.8 $(DESTDIR)/usr/man/man8/vsftpd.8
+ $(INSTALL) -D -m 644 vsftpd.conf.5 $(DESTDIR)/usr/man/man5/vsftpd.conf.5
+ $(INSTALL) -D -m 600 vsftpd.conf $(DESTDIR)/etc/vsftpd.conf
clean:
rm -f *.o *.swp vsftpd
diff -Nru vsftpd-2.0.4.orig/builddefs.h vsftpd-2.0.4/builddefs.h
--- vsftpd-2.0.4.orig/builddefs.h 2006-01-10 19:25:18.000000000 +0100
+++ vsftpd-2.0.4/builddefs.h 2006-01-10 19:25:36.000000000 +0100
@@ -1,9 +1,9 @@
#ifndef VSF_BUILDDEFS_H
#define VSF_BUILDDEFS_H
-#undef VSF_BUILD_TCPWRAPPERS
-#define VSF_BUILD_PAM
-#undef VSF_BUILD_SSL
+#define VSF_BUILD_TCPWRAPPERS
+#undef VSF_BUILD_PAM
+#define VSF_BUILD_SSL
#endif /* VSF_BUILDDEFS_H */
diff -Nru vsftpd-2.0.4.orig/tunables.c vsftpd-2.0.4/tunables.c
--- vsftpd-2.0.4.orig/tunables.c 2006-01-10 19:25:18.000000000 +0100
+++ vsftpd-2.0.4/tunables.c 2006-01-10 19:25:36.000000000 +0100
@@ -92,7 +92,7 @@
unsigned int tunable_max_per_ip = 0;
unsigned int tunable_trans_chunk_size = 0;
-const char* tunable_secure_chroot_dir = "/usr/share/empty";
+const char* tunable_secure_chroot_dir = "/var/empty";
const char* tunable_ftp_username = "ftp";
const char* tunable_chown_username = "root";
const char* tunable_xferlog_file = "/var/log/xferlog";
@@ -117,7 +117,7 @@
const char* tunable_deny_file = 0;
const char* tunable_user_sub_token = 0;
const char* tunable_email_password_file = "/etc/vsftpd.email_passwords";
-const char* tunable_rsa_cert_file = "/usr/share/ssl/certs/vsftpd.pem";
+const char* tunable_rsa_cert_file = "/etc/ssl/certs/vsftpd.pem";
const char* tunable_dsa_cert_file = 0;
const char* tunable_ssl_ciphers = "DES-CBC3-SHA";
const char* tunable_rsa_private_key_file = 0;
diff -Nru vsftpd-2.0.4.orig/vsftpd.conf vsftpd-2.0.4/vsftpd.conf
--- vsftpd-2.0.4.orig/vsftpd.conf 2006-01-10 19:25:18.000000000 +0100
+++ vsftpd-2.0.4/vsftpd.conf 2006-01-10 19:25:36.000000000 +0100
@@ -8,11 +8,23 @@
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
+#
+# Run standalone
+listen=YES
+#
+# Use tcp_wrappers library
+tcp_wrappers=YES
+#
+# Enable SSL support
+ssl_enable=YES
+ssl_sslv3=YES
+#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=YES
#
# Uncomment this to allow local users to log in.
#local_enable=YES
+#force_local_logins_ssl=YES
#
# Uncomment this to enable any form of FTP write command.
#write_enable=YES
diff -Nru vsftpd-2.0.4.orig/vsftpd.conf.5 vsftpd-2.0.4/vsftpd.conf.5
--- vsftpd-2.0.4.orig/vsftpd.conf.5 2006-01-10 19:25:18.000000000 +0100
+++ vsftpd-2.0.4/vsftpd.conf.5 2006-01-10 19:25:36.000000000 +0100
@@ -844,7 +844,7 @@
This option specifies the location of the RSA certificate to use for SSL
encrypted connections.
-Default: /usr/share/ssl/certs/vsftpd.pem
+Default: /etc/ssl/certs/vsftpd.pem
.TP
.B rsa_private_key_file
This option specifies the location of the RSA private key to use for SSL
@@ -858,7 +858,7 @@
directory should not be writable by the ftp user. This directory is used
as a secure chroot() jail at times vsftpd does not require filesystem access.
-Default: /usr/share/empty
+Default: /var/empty
.TP
.B ssl_ciphers
This option can be used to select which SSL ciphers vsftpd will allow for