opt/xulrunner/xulrunner.diff
2009-11-04 19:25:53 +01:00

68 lines
3.3 KiB
Diff

diff -Naur mozilla-1.9.1/xulrunner/installer/libxul-embedding.pc.in mozilla-1.9.1.new/xulrunner/installer/libxul-embedding.pc.in
--- mozilla-1.9.1/xulrunner/installer/libxul-embedding.pc.in 2009-10-16 17:14:30.000000000 +0200
+++ mozilla-1.9.1.new/xulrunner/installer/libxul-embedding.pc.in 2009-10-29 23:12:07.687729216 +0100
@@ -12,4 +12,4 @@
Description: Static library for version-independent embedding of the Mozilla runtime
Version: %MOZILLA_VERSION%
Libs: -L${sdkdir}/lib -lxpcomglue
-Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS%
+Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS% %FULL_NSPR_CFLAGS%
diff -Naur mozilla-1.9.1/xulrunner/installer/libxul-embedding-unstable.pc.in mozilla-1.9.1.new/xulrunner/installer/libxul-embedding-unstable.pc.in
--- mozilla-1.9.1/xulrunner/installer/libxul-embedding-unstable.pc.in 2009-10-16 17:14:30.000000000 +0200
+++ mozilla-1.9.1.new/xulrunner/installer/libxul-embedding-unstable.pc.in 2009-10-29 23:12:07.686727554 +0100
@@ -8,4 +8,4 @@
Description: Static library for version-independent embedding of the Mozilla runtime (unstable API)
Version: %MOZILLA_VERSION%
Libs: -L${sdkdir}/lib -lxpcomglue
-Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS%
+Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS% %FULL_NSPR_CFLAGS%
diff -Naur mozilla-1.9.1/xulrunner/installer/Makefile.in mozilla-1.9.1.new/xulrunner/installer/Makefile.in
--- mozilla-1.9.1/xulrunner/installer/Makefile.in 2009-10-16 17:14:30.000000000 +0200
+++ mozilla-1.9.1.new/xulrunner/installer/Makefile.in 2009-10-29 23:12:07.685747405 +0100
@@ -96,19 +96,28 @@
ifdef MOZ_NATIVE_NSPR
NSPR_NAME=nspr
NSPR_VERSION=$(shell $(NSPR_CONFIG) --version)
+FULL_NSPR_CFLAGS=$(shell $(NSPR_CONFIG) --cflags)
+FULL_NSPR_LIBS=$(shell $(NSPR_CONFIG) --libs)
else
-pkg_config_files += mozilla-nspr.pc
NSPR_NAME=mozilla-nspr
FULL_NSPR_CFLAGS=-I\$${includedir}/stable
FULL_NSPR_LIBS=$(subst $(prefix),\$${sdkdir},$(shell $(DEPTH)/nsprpub/config/nspr-config --libs))
NSPR_VERSION=$(shell $(DEPTH)/nsprpub/config/nspr-config --version)
endif
+pkg_config_files += mozilla-nspr.pc
$(warning FULL_NSPR_CFLAGS=$(FULL_NSPR_CFLAGS))
-ifndef MOZ_NATIVE_NSS
-pkg_config_files += mozilla-nss.pc
+ifdef MOZ_NATIVE_NSS
+NSPR_VERSION=$(shell $(NSS_CONFIG) --version)
+FULL_NSS_CFLAGS=$(shell $(NSS_CONFIG) --cflags)
+FULL_NSS_LIBS=$(shell $(NSS_CONFIG) --libs)
+else
+NSS_VERSION=$(shell $(DEPTH)/nsprpub/config/nss-config --version)
+FULL_NSS_CFLAGS=-I\$${includedir}/stable
+FULL_NSS_LIBS=$(subst $(prefix),\$${sdkdir},$(shell $(DEPTH)/nsprpub/config/nss-config --libs))
endif
+pkg_config_files += mozilla-nss.pc
ifdef MOZ_OJI
OJIDEF=-DOJI
diff -Naur mozilla-1.9.1/xulrunner/installer/mozilla-nss.pc.in mozilla-1.9.1.new/xulrunner/installer/mozilla-nss.pc.in
--- mozilla-1.9.1/xulrunner/installer/mozilla-nss.pc.in 2009-10-16 17:14:30.000000000 +0200
+++ mozilla-1.9.1.new/xulrunner/installer/mozilla-nss.pc.in 2009-10-29 23:21:10.524863538 +0100
@@ -4,7 +4,7 @@
Name: NSS
Description: Mozilla Network Security Services
-Version: %MOZILLA_VERSION%
+Version: %NSS_VERSION%
Requires: %NSPR_NAME% >= %NSPR_VERSION%
-Libs: -L${sdkdir}/lib -lsmime3 -lssl3 -lnss3 -lnssutil3
-Cflags: -I${includedir}/stable
+Libs: %FULL_NSS_LIBS%
+Cflags: %FULL_NSS_CFLAGS%