opt/dnsmasq/dnsmasq-config.patch

66 lines
2.2 KiB
Diff

diff -Nru dnsmasq-2.57.orig/Makefile dnsmasq-2.57/Makefile
--- dnsmasq-2.57.orig/Makefile 2011-02-18 19:40:32.338780931 +0100
+++ dnsmasq-2.57/Makefile 2011-02-18 19:41:05.227367036 +0100
@@ -15,7 +15,7 @@
PREFIX = /usr/local
BINDIR = ${PREFIX}/sbin
-MANDIR = ${PREFIX}/share/man
+MANDIR = ${PREFIX}/man
LOCALEDIR = ${PREFIX}/share/locale
PKG_CONFIG = pkg-config
@@ -24,7 +24,7 @@
MSGFMT = msgfmt
XGETTEXT = xgettext
-CFLAGS = -Wall -W -O2
+CFLAGS += -Wall -W
#################################################################
diff -Nru dnsmasq-2.57.orig/dnsmasq.conf.example dnsmasq-2.57/dnsmasq.conf.example
--- dnsmasq-2.57.orig/dnsmasq.conf.example 2011-02-18 19:40:32.342114459 +0100
+++ dnsmasq-2.57/dnsmasq.conf.example 2011-02-18 19:41:05.227367036 +0100
@@ -75,8 +75,8 @@
# If you want dnsmasq to change uid and gid to something other
# than the default, edit the following lines.
-#user=
-#group=
+#user=nobody
+#group=nobody
# If you want dnsmasq to listen for DHCP and DNS requests only on
# specified interfaces (and the loopback) give the name of the
@@ -428,7 +428,7 @@
# The DHCP server needs somewhere on disk to keep its lease database.
# This defaults to a sane location, but if you want to change it, use
# the line below.
-#dhcp-leasefile=/var/lib/misc/dnsmasq.leases
+# dhcp-leasefile=/var/lib/dhcp/dnsmasq.leases
# Set the DHCP server to authoritative mode. In this mode it will barge in
# and take over the lease for any client which broadcasts on the network,
diff -Nru dnsmasq-2.57.orig/src/config.h dnsmasq-2.57/src/config.h
--- dnsmasq-2.57.orig/src/config.h 2011-02-18 19:40:32.342114459 +0100
+++ dnsmasq-2.57/src/config.h 2011-02-18 19:41:55.626975423 +0100
@@ -49,7 +49,7 @@
# elif defined(__ANDROID__)
# define LEASEFILE "/data/misc/dhcp/dnsmasq.leases"
# else
-# define LEASEFILE "/var/lib/misc/dnsmasq.leases"
+# define LEASEFILE "/var/lib/dhcp/dnsmasq.leases"
# endif
#endif
@@ -63,7 +63,7 @@
#define DEFLEASE 3600 /* default lease time, 1 hour */
#define CHUSER "nobody"
-#define CHGRP "dip"
+#define CHGRP "nobody"
#define NAMESERVER_PORT 53
#define DHCP_SERVER_PORT 67
#define DHCP_CLIENT_PORT 68