libxfcegui4: fixed build issues against last libxfce4util

https://bugzilla.xfce.org/show_bug.cgi?id=10974
This commit is contained in:
Jose V Beneyto 2015-03-15 21:00:28 +01:00
parent 0c125f69a9
commit cac3aa6fb8
3 changed files with 20 additions and 2 deletions

View File

@ -1 +1,2 @@
4025b9d6811f051c914cdd700d437e61 libxfcegui4-4.10.0.tar.bz2
e57b7c546ebe1f43bf1f222b6e57c6b9 no-xfce_setenv.patch

View File

@ -7,12 +7,15 @@
name=libxfcegui4
version=4.10.0
release=1
source=(http://archive.xfce.org/src/xfce/$name/${version%.*}/$name-$version.tar.bz2)
release=2
source=(http://archive.xfce.org/src/xfce/$name/${version%.*}/$name-$version.tar.bz2 \
no-xfce_setenv.patch)
build () {
cd $name-$version
patch -p0 -i $SRC/no-xfce_setenv.patch
sed -e '/^AC_PROG_INTLTOOL/d' -i configure.in
sed -e '/^SUBDIRS/s/po//' -i Makefile.in

View File

@ -0,0 +1,14 @@
http://bugs.gentoo.org/513568
http://bugzilla.xfce.org/show_bug.cgi?id=10974
--- libxfcegui4/xfce-exec.c
+++ libxfcegui4/xfce-exec.c
@@ -79,7 +79,7 @@
#ifndef G_OS_WIN32
gchar *dpyname = user_data;
- xfce_setenv ("DISPLAY", dpyname, TRUE);
+ g_setenv ("DISPLAY", dpyname, TRUE);
#endif
}