xorg-server: added another patch from arch to match autotools behaviour

This commit is contained in:
Tim Biermann 2021-09-20 12:13:04 +02:00
parent eb34d750a4
commit 23c93e11fb
3 changed files with 36 additions and 3 deletions

View File

@ -1,7 +1,8 @@
untrusted comment: verify with /etc/ports/xorg.pub
RWTSGWF5Q7TndEoK0L1fFjTMw5A7u0JA3TZLHVnXlipQmXhkoHynUQpEdCHkiryINOU1+WqosQPnTv3qKzNjrCW9MQRUuLk1dQ0=
SHA256 (Pkgfile) = dd85837f7c8fc4c0a431080b9577826c6bd5f06903c528e336bf2503352ac339
RWTSGWF5Q7TndADIbXLkJ3/NYWBCfIdJouEYcl1T/WrdPwOZRB5uj+XyOYnVswbq+z/3maxuTMHGZ/NlfmvU4WAm5T9uKAoDVws=
SHA256 (Pkgfile) = a67c531a31dd106afc454015f2f1c4dfba4c2bea00b1e6173a1a8d444bc4fcaa
SHA256 (.footprint) = 22ebe7390e74b30e28ca4833bba98490684c8b6258af9ee17d5940a114732333
SHA256 (xorg-server-1.20.13.tar.xz) = 40aa4e96a56a81a301f15a9b10e06a22700f12b42d9e0e453c7f11d354386300
SHA256 (0001-v2-FS-58644.patch) = 6253fb5cf06cf650539be585d6ca13cfa00217b51ca9825476c8fd55c09341a4
SHA256 (xserver-autobind-hotplug.patch) = cae1b7f296c18177de38f9b1215a4f916da2288b85f1fcb9e80373a42e2892b8
SHA256 (0002-fix-libshadow-2.patch) = d07b2fe55828dad61517a80c77f6f183113916f5e1fce30ff43041550d58bd6e

View File

@ -0,0 +1,30 @@
From a530b6e8923f2b9153a773c8618a1e2f41619288 Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Tue, 30 Apr 2019 18:01:27 -0400
Subject: [PATCH] meson: Fix libshadow.so linkage
Don't link against fb, it's the driver's responsibility to load that
first. Underlinking like this is unpleasant but this matches what
autotools does.
Fixes: xorg/xserver#540
---
hw/xfree86/dixmods/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/hw/xfree86/dixmods/meson.build b/hw/xfree86/dixmods/meson.build
index 835d23215..0562b630f 100644
--- a/hw/xfree86/dixmods/meson.build
+++ b/hw/xfree86/dixmods/meson.build
@@ -34,7 +34,7 @@ shared_module(
c_args: xorg_c_args,
dependencies: common_dep,
link_whole: libxserver_miext_shadow,
- link_with: [fb, e],
+ link_with: e,
install: true,
install_dir: module_dir,
--
2.22.0

View File

@ -7,11 +7,13 @@ name=xorg-server
version=1.20.13
release=2
source=(https://www.x.org/releases/individual/xserver/$name-$version.tar.xz
0001-v2-FS-58644.patch xserver-autobind-hotplug.patch)
0001-v2-FS-58644.patch xserver-autobind-hotplug.patch
0002-fix-libshadow-2.patch)
build() {
# https://bugs.freedesktop.org/show_bug.cgi?id=106588
patch -Np1 -d $SRC/$name-$version -i $SRC/0001-v2-FS-58644.patch
patch -Np1 -d $SRC/$name-$version -i $SRC/0002-fix-libshadow-2.patch
patch -Np1 -d $SRC/$name-$version -i $SRC/xserver-autobind-hotplug.patch
meson setup $name-$version build \