mesa: 24.2.2 -> 24.2.3

This commit is contained in:
Tim Biermann 2024-09-19 20:52:49 +02:00
parent 9bbbc42a5c
commit 4af8e0c5f6
Signed by: tb
GPG Key ID: 42F8B4E30B673606
4 changed files with 7 additions and 54 deletions

View File

@ -34,7 +34,7 @@ lrwxrwxrwx root/root usr/lib/libGLX_mesa.so.0 -> libGLX_mesa.so.0.0.0
lrwxrwxrwx root/root usr/lib/libOSMesa.so -> libOSMesa.so.8
lrwxrwxrwx root/root usr/lib/libOSMesa.so.8 -> libOSMesa.so.8.0.0
-rwxr-xr-x root/root usr/lib/libOSMesa.so.8.0.0
-rwxr-xr-x root/root usr/lib/libgallium-24.2.2-1.so
-rwxr-xr-x root/root usr/lib/libgallium-24.2.3-1.so
lrwxrwxrwx root/root usr/lib/libgbm.so -> libgbm.so.1
lrwxrwxrwx root/root usr/lib/libgbm.so.1 -> libgbm.so.1.0.0
-rwxr-xr-x root/root usr/lib/libgbm.so.1.0.0

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/xorg.pub
RWTSGWF5Q7TndLS4i2sB9HhUyUI4hpaU+pABaCnSGRzjDUZZe1sDg5SX+pFkOfQ7dQaNV9HqLyEBZ2AKUqMOIfzXX0iGpsu0ywY=
SHA256 (Pkgfile) = 1766f78e2a6fdf97355a9394a926f62ad1f2219dedebeb335d5ef7a63efafa1f
SHA256 (.footprint) = f0e596f393ccf0cfe7818210b81f5314d3457e1f12de25c0503f2af08a46e078
SHA256 (mesa-24.2.2.tar.xz) = fd077d3104edbe459e2b8597d2757ec065f9bd2d620b8c0b9cc88c2bf9891d02
SHA256 (30710.patch) = 7c5cfd5c767668cfc7e91542e0f837b0b4749d67a7eafe849a6565b8fc54e512
RWTSGWF5Q7TndEwQqmPeMWr4s2NaTYWVnZXQRC/PchL+z0Bz7+tJ1cp0/Mcmul6fDGISb2eTE0svfulu/ngNSLEG3hOEgNWr0A0=
SHA256 (Pkgfile) = 90d5e15e0543f84c315cfdb7e41535b6f21f382cd15812de08109e0f501f2be4
SHA256 (.footprint) = 135c3a6c97358296e269d2c8aa4c1a7ec27ced4a4afd8271fb3d39e5e30aab14
SHA256 (mesa-24.2.3.tar.xz) = 4ea18b1155a4544a09f7361848974768f6f73c19d88f63de2ec650be313b2d0c

View File

@ -1,43 +0,0 @@
From 93e96da9458c9d0348f2390dc0bea67cf140b1a0 Mon Sep 17 00:00:00 2001
From: Karol Herbst <kherbst@redhat.com>
Date: Sun, 18 Aug 2024 00:08:50 +0200
Subject: [PATCH] rusticl: do not use CL vector types in bindings and code
Bindgen seems to miscompile them and I kinda thought I've done this
already in the past, but apparently not.
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/11722
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/30710>
---
src/gallium/frontends/rusticl/api/device.rs | 2 +-
src/gallium/frontends/rusticl/meson.build | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/gallium/frontends/rusticl/api/device.rs b/src/gallium/frontends/rusticl/api/device.rs
index 9793092db5ad4..c1cb7902e0371 100644
--- a/src/gallium/frontends/rusticl/api/device.rs
+++ b/src/gallium/frontends/rusticl/api/device.rs
@@ -196,7 +196,7 @@ impl CLInfo<cl_device_info> for cl_device_id {
// TODO proper retrival from devices
CL_DEVICE_MEM_BASE_ADDR_ALIGN => cl_prop::<cl_uint>(0x1000),
CL_DEVICE_MIN_DATA_TYPE_ALIGN_SIZE => {
- cl_prop::<cl_uint>(size_of::<cl_ulong16>() as cl_uint)
+ cl_prop::<cl_uint>(16 * size_of::<cl_ulong>() as cl_uint)
}
CL_DEVICE_NAME => cl_prop::<&str>(&dev.screen().name()),
CL_DEVICE_NATIVE_VECTOR_WIDTH_CHAR => cl_prop::<cl_uint>(1),
diff --git a/src/gallium/frontends/rusticl/meson.build b/src/gallium/frontends/rusticl/meson.build
index 612e47bfe88e1..1fe75a611444d 100644
--- a/src/gallium/frontends/rusticl/meson.build
+++ b/src/gallium/frontends/rusticl/meson.build
@@ -146,6 +146,7 @@ rusticl_opencl_bindings_rs = rust.bindgen(
'--raw-line', 'unsafe impl std::marker::Send for _cl_image_desc {}',
'--raw-line', 'unsafe impl std::marker::Sync for _cl_image_desc {}',
'--allowlist-type', 'cl_.*',
+ '--blocklist-type', '(__)?cl_.*[2348(16)]',
'--allowlist-type', 'cl.*_fn',
'--allowlist-var', 'CL_.*',
# needed for gl_sharing extension
--
GitLab

View File

@ -5,10 +5,9 @@
# Optional: cbindgen directx-headers glslang libclc libunwind libva libvdpau lm_sensors lua python3-ply rust-bindgen spirv-llvm-translator vulkan-loader wayland-protocols
name=mesa
version=24.2.2
version=24.2.3
release=1
source=(https://archive.mesa3d.org/$name-$version.tar.xz
30710.patch)
source=(https://archive.mesa3d.org/$name-$version.tar.xz)
build() {
prt-get isinst directx-headers && PKGMK_MESA_GALLIUM+='d3d12,'
@ -36,8 +35,6 @@ build() {
printf '%s' "$version-$release" > $name-$version/VERSION
patch -Np1 -d $name-$version -i $SRC/30710.patch
meson setup build $name-$version $PKGMK_MESA \
--prefix=/usr \
--sysconfdir=/etc \