thunderbird:: fix build for rust 1.50.0

This commit is contained in:
Danny Rawlins 2021-02-15 21:31:36 +11:00
parent 4ddc8c42f1
commit fc148a8116
3 changed files with 81 additions and 4 deletions

View File

@ -1,6 +1,7 @@
untrusted comment: verify with /etc/ports/contrib.pub
RWSagIOpLGJF32Ow4RlyPBWvqNihPuyBT1Th3PM1KlBAVcpYCT9GQG+0ISkBZjy+EAseB6EjWCX5m0e7M4jP3Bz6mQsyaagBdAU=
SHA256 (Pkgfile) = 5c3582dbb1b781648ccd7cad32a3cb7f67939cbc70ad94a34632abb7e36c37c3
RWSagIOpLGJF37fvFgv87ZJei3NV17f+idUbRLQKaa3ZapThEQmnrjlTMiRpQNPPJRANM53hWnlS6LBHesfaflVLOivqfm02lws=
SHA256 (Pkgfile) = 16aa88fccbe3cdab386ba46ba97731aa7c3002c5f5e2a2799d56022386b5301a
SHA256 (.footprint) = 6b9d0cf535593004cc52a1235980afb12eab4471e85cd6f32a7e5844d8193651
SHA256 (thunderbird-78.7.1.source.tar.xz) = 0ccc5a54fb2548489c9579f677cb4ff3c191b1d1fcf33bef6b1cf6eb704e385a
SHA256 (thunderbird.desktop) = c6bc6a66f16951c4f7560d019dad48968169aef6587cef4e98380a300078299a
SHA256 (fix-rust-1.50-build.patch) = 4f87f2901a0f3cbe7956d4ed8656a6881e331bb82c32907ae42146b7901ec2ee

View File

@ -6,13 +6,16 @@
name=thunderbird
version=78.7.1
release=1
release=2
source=(https://archive.mozilla.org/pub/thunderbird/releases/$version/source/$name-$version.source.tar.xz
$name.desktop)
$name.desktop
fix-rust-1.50-build.patch)
build() {
cd $name-$version
patch -p0 -i $SRC/fix-rust-1.50-build.patch
if [ -e '/usr/bin/ccache' ]; then
export OS_CCACHE_COMPILERCHECK="$(/usr/bin/clang -dumpversion | sed -z 's/\n/ /g'; crux | cut -d' ' -f3)"
export CCACHE_COMPILERCHECK="string:$OS_CCACHE_COMPILERCHECK"

View File

@ -0,0 +1,73 @@
# HG changeset patch
# User Emilio Cobos Álvarez <emilio@crisal.io>
# Date 1609006565 0
# Node ID 0e8f444683cb9c4079d3b2250f32f986043ea582
# Parent 55097a5cf353f1b2a2228820bdf26bb69a1372a0
Bug 1684261 - Fix build with rust nightly. r=jrmuizel, a=RyanVM
Fixes errors like:
dependency (nix) specification is ambiguous. Only one of `branch`, `tag` or `rev` is allowed.
I've left the most specific dependency, but for wgpu the rev is not
right, so I've kept the branch which effectively preserves behavior.
Differential Revision: https://phabricator.services.mozilla.com/D100485
diff --git a/.cargo/config.in b/.cargo/config.in
--- .cargo/config.in
+++ .cargo/config.in
@@ -1,16 +1,16 @@
# This file contains vendoring instructions for cargo.
# It was generated by `mach vendor rust`.
# Please do not edit.
[source."https://github.com/shravanrn/nix/"]
-branch = "r0.13.1"
git = "https://github.com/shravanrn/nix/"
replace-with = "vendored-sources"
+rev = "4af6c367603869a30fddb5ffb0aba2b9477ba92e"
[source."https://github.com/mozilla/rkv"]
git = "https://github.com/mozilla/rkv"
replace-with = "vendored-sources"
rev = "e3c3388e6632cf55e08d773b32e58b1cab9b2731"
[source."https://github.com/mozilla/neqo"]
git = "https://github.com/mozilla/neqo"
diff --git a/Cargo.lock b/Cargo.lock
--- Cargo.lock
+++ Cargo.lock
@@ -3195,17 +3195,17 @@ source = "registry+https://github.com/ru
checksum = "0cdc457076c78ab54d5e0d6fa7c47981757f1e34dc39ff92787f217dede586c4"
dependencies = [
"unreachable",
]
[[package]]
name = "nix"
version = "0.13.1"
-source = "git+https://github.com/shravanrn/nix/?branch=r0.13.1#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+source = "git+https://github.com/shravanrn/nix/?rev=4af6c367603869a30fddb5ffb0aba2b9477ba92e#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
dependencies = [
"bitflags",
"cc",
"cfg-if",
"libc",
"void",
]
--- Cargo.toml
+++ Cargo.toml
@@ -68,8 +68,8 @@ panic = "abort"
libudev-sys = { path = "dom/webauthn/libudev-sys" }
packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="0917fe780032a6bbb23d71be545f9c1834128d75" }
rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="d510da5999a744c563b0acd18056069d1698273f" }
-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3", rev = "20191ad2f370afd6d247edcb9ff9da32d3bedb9c" }
+nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
+spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3" }
# failure's backtrace feature might break our builds, see bug 1608157.
failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }