44 lines
1.6 KiB
Diff
44 lines
1.6 KiB
Diff
diff -ru wmdiscotux-1.3-orig/Makefile wmdiscotux-1.3/Makefile
|
|
--- wmdiscotux-1.3-orig/Makefile 2000-11-15 20:33:43.000000000 +0200
|
|
+++ wmdiscotux-1.3/Makefile 2006-01-29 13:11:51.000000000 +0200
|
|
@@ -1,6 +1,6 @@
|
|
CC = gcc
|
|
-INCLUDEDIR = -I/usr/include -I/usr/X11R6/include -I/usr/local/include
|
|
-CFLAGS = -O2 -Wall $(INCLUDEDIR) -fPIC `glib-config --cflags`
|
|
+INCLUDEDIR = -I/usr/include/gtk-1.2 -I/usr/include -I/usr/X11R6/include
|
|
+CFLAGS += -Wall $(INCLUDEDIR) -fPIC `glib-config --cflags`
|
|
LFLAGS = -shared -fPIC -lpthread -L/usr/lib -ldl -lm -L/usr/X11R6/lib -lXpm -lX11
|
|
|
|
libwmdiscotux.so: wmdiscotux.o wmgeneral.o
|
|
@@ -10,5 +10,5 @@
|
|
rm -f *.o core *.so*
|
|
|
|
install: libwmdiscotux.so
|
|
- cp libwmdiscotux.so `xmms-config --visualization-plugin-dir`
|
|
+ /usr/bin/install -D -o 0 -g 0 -s -m 755 libwmdiscotux.so $(PKG)`xmms-config --visualization-plugin-dir`/libwmdiscotux.so
|
|
|
|
diff -ru wmdiscotux-1.3-orig/wmdiscotux.c wmdiscotux-1.3/wmdiscotux.c
|
|
--- wmdiscotux-1.3-orig/wmdiscotux.c 2000-11-16 16:51:52.000000000 +0200
|
|
+++ wmdiscotux-1.3/wmdiscotux.c 2006-01-29 12:56:57.000000000 +0200
|
|
@@ -359,16 +359,10 @@
|
|
gtk_container_border_width(GTK_CONTAINER(dialog), 5);
|
|
|
|
|
|
- label = gtk_label_new ("
|
|
-wmDiscoTux\n\
|
|
-v " VERSION "\n\
|
|
-
|
|
-by Antti Takala <fragment@nic.fi>\n\
|
|
-
|
|
-get the newest version from:\n\
|
|
-http://wmdiscotux.stc.cx/\n\
|
|
-
|
|
-");
|
|
+ label = gtk_label_new ("\nwmDiscoTux\n\\n\
|
|
+v " VERSION "\n\\n\nby Antti Takala <fragment@nic.fi>\n\\n\n\
|
|
+get the newest version from:\n\\n\
|
|
+http://wmdiscotux.stc.cx/\n\\n\n");
|
|
|
|
gtk_box_pack_start(GTK_BOX(GTK_DIALOG(dialog)->vbox), label, FALSE, FALSE, 0);
|
|
gtk_widget_show(label);
|