29 lines
1.1 KiB
Diff
29 lines
1.1 KiB
Diff
diff -Naur dragonbox-1.1.3.orig/CMakeLists.txt dragonbox-1.1.3/CMakeLists.txt
|
|
--- dragonbox-1.1.3.orig/CMakeLists.txt 2022-07-17 01:40:02.730339794 +0200
|
|
+++ dragonbox-1.1.3/CMakeLists.txt 2022-07-17 01:42:08.326148387 +0200
|
|
@@ -57,8 +57,7 @@
|
|
"When invoked with --install, dragonbox_to_chars.h/.cpp are installed along with dragonbox.h"
|
|
On)
|
|
|
|
-set(dragonbox_directory "dragonbox-${PROJECT_VERSION}")
|
|
-set(dragonbox_include_directory "${CMAKE_INSTALL_INCLUDEDIR}/${dragonbox_directory}")
|
|
+set(dragonbox_include_directory "${CMAKE_INSTALL_INCLUDEDIR}/")
|
|
set(dragonbox_install_targets "dragonbox")
|
|
|
|
if (DRAGONBOX_INSTALL_TO_CHARS)
|
|
@@ -73,6 +72,7 @@
|
|
INCLUDES #
|
|
DESTINATION "${dragonbox_include_directory}")
|
|
|
|
+set(dragonbox_directory "dragonbox-${PROJECT_VERSION}")
|
|
set(dragonbox_install_cmakedir "${CMAKE_INSTALL_LIBDIR}/cmake/${dragonbox_directory}")
|
|
|
|
write_basic_package_version_file(
|
|
@@ -120,4 +120,4 @@
|
|
/Zi /permissive-
|
|
$<$<NOT:$<CXX_COMPILER_ID:Clang>>:/experimental:newLambdaProcessor>
|
|
$<$<CONFIG:Release>:/GL>)
|
|
-endif()
|
|
\ No newline at end of file
|
|
+endif()
|