contrib/firefox/fix-rust-1.50-build.patch
2021-02-15 21:31:46 +11:00

39 lines
2.3 KiB
Diff

diff -pruN firefox-85.0.2.orig/.cargo/config.in firefox-85.0.2/.cargo/config.in
--- firefox-85.0.2.orig/.cargo/config.in 2021-02-15 19:15:28.519967793 +1100
+++ firefox-85.0.2/.cargo/config.in 2021-02-15 19:16:49.418429299 +1100
@@ -3,7 +3,7 @@
# Please do not edit.
[source."https://github.com/shravanrn/nix/"]
-branch = "r0.13.1"
+rev = "4af6c367603869a30fddb5ffb0aba2b9477ba92e"
git = "https://github.com/shravanrn/nix/"
replace-with = "vendored-sources"
diff -pruN firefox-85.0.2.orig/Cargo.lock firefox-85.0.2/Cargo.lock
--- firefox-85.0.2.orig/Cargo.lock 2021-02-15 19:15:28.527968036 +1100
+++ firefox-85.0.2/Cargo.lock 2021-02-15 19:21:02.839140162 +1100
@@ -3409,7 +3409,7 @@ dependencies = [
[[package]]
name = "nix"
version = "0.13.1"
-source = "git+https://github.com/shravanrn/nix/?branch=r0.13.1#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+source = "git+https://github.com/shravanrn/nix/?rev=4af6c367603869a30fddb5ffb0aba2b9477ba92e#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
dependencies = [
"bitflags",
"cc",
diff -pruN firefox-85.0.2.orig/Cargo.toml firefox-85.0.2/Cargo.toml
--- firefox-85.0.2.orig/Cargo.toml 2021-02-15 19:15:26.631910345 +1100
+++ firefox-85.0.2/Cargo.toml 2021-02-15 19:24:17.448061552 +1100
@@ -76,8 +76,8 @@ chardetng = { git = "https://github.com/
libudev-sys = { path = "dom/webauthn/libudev-sys" }
packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="0917fe780032a6bbb23d71be545f9c1834128d75" }
rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="f3cace4fb8b53db0849c62af4fa62bade5a620f7" }
-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu4", rev = "e9eff10f964957e7a001c5f712effe17ce09aa99" }
+nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
+spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu4" }
# failure's backtrace feature might break our builds, see bug 1608157.
failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }