Merge remote-tracking branch 'origin/3.7' into 3.8

This commit is contained in:
Juergen Daubert 2024-04-09 17:14:57 +02:00
commit a161c4f78c
19 changed files with 45 additions and 86 deletions

View File

@ -985,6 +985,7 @@ drwxr-xr-x root/root usr/share/cmake/Modules/Platform/Android/
-rw-r--r-- root/root usr/share/cmake/Modules/Platform/Haiku-Initialize.cmake
-rw-r--r-- root/root usr/share/cmake/Modules/Platform/Haiku.cmake
-rw-r--r-- root/root usr/share/cmake/Modules/Platform/Linux-Absoft-Fortran.cmake
-rw-r--r-- root/root usr/share/cmake/Modules/Platform/Linux-Apple-Swift.cmake
-rw-r--r-- root/root usr/share/cmake/Modules/Platform/Linux-CCur-Fortran.cmake
-rw-r--r-- root/root usr/share/cmake/Modules/Platform/Linux-Clang-C.cmake
-rw-r--r-- root/root usr/share/cmake/Modules/Platform/Linux-Clang-CUDA.cmake

View File

@ -1,5 +1,5 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVeqhx/C7RUZq0/9Mozm3ui8AsBXJXpTxAD6gO/86iGia7LJNaU15/btaQDo5paLdUQ/DJkaoQ6aeYWE6xe7tezVgM=
SHA256 (Pkgfile) = 243a5ab757194a083d2e8189c19dc9361cd724b0c2eac56d0a409a7f7249cf4a
SHA256 (.footprint) = 6d0d55c975be2049f3d5b2c2b2be6df7ea9022830328ef8c8aaafec2a253557d
SHA256 (cmake-3.29.0.tar.gz) = a0669630aae7baa4a8228048bf30b622f9e9fd8ee8cedb941754e9e38686c778
RWRJc1FUaeVeqrGhesI7ybTanstn3uM+wD9wk21n07soqaf6GsnmFIK1rD1wYNBYnAWjcP5bsfdCIAsW+CohVZOhjq8uLkJyLAw=
SHA256 (Pkgfile) = f17a6c80d45e6fc63b8ce3cb99691f2efb53a29fa1d40511d743e5ac034c7a56
SHA256 (.footprint) = cf4e85c2ce9c337ffd51137882030a7e373e613c478762f63910f63b4faae807
SHA256 (cmake-3.29.1.tar.gz) = 7fb02e8f57b62b39aa6b4cf71e820148ba1a23724888494735021e32ab0eefcc

View File

@ -5,7 +5,7 @@
# Optional: python3-sphinx
name=cmake
version=3.29.0
version=3.29.1
release=1
source=(https://cmake.org/files/v${version%.*}/$name-$version.tar.gz)

View File

@ -1,6 +1,5 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVeqig5jKE9SDx4sbdp2u6tGGD7o4Ik1D3K0/iebRRps2dq7zRUC/EfktTftN6jmOf/RElBl0Y+Myz3tm7k3+0v3ws=
SHA256 (Pkgfile) = f1c2f8b66cafdf1f61f14371e4618d04112cf4938b35aeff6318d16f1300c648
RWRJc1FUaeVeqilrxMpI8R7786qQ7qHxc8ZVMAu+9p7SUgRB+NQT7A9ECoyBA3u+iiJhgc+kq45IRdEWUjowmBoCC6EJcXCg3AA=
SHA256 (Pkgfile) = 58a0620624697ca357eb1a99f2ef576c14a6c803067be6833f36980c627a3374
SHA256 (.footprint) = 297bc91d57d21039ca861bbbc40537465edfede236532f8caec8434129f5c880
SHA256 (libarchive-3.7.2.tar.xz) = 04357661e6717b6941682cde02ad741ae4819c67a260593dfb2431861b251acb
SHA256 (lzma_stream.patch) = 0ef35ac67530d5ae3e4e39d968c4ba72a7a9806e4d98aa16aa8b608c76eb32c8
SHA256 (libarchive-3.7.3.tar.xz) = 63e7a7174638fc7d6b79b4c8b0ad954e0f4f45abe7239c1ecb200232aa9a43d2

View File

@ -4,14 +4,11 @@
# Depends on: acl bzip2 lzo zstd
name=libarchive
version=3.7.2
release=2
source=(https://github.com/libarchive/libarchive/releases/download/v$version/$name-$version.tar.xz
lzma_stream.patch)
version=3.7.3
release=1
source=(https://github.com/libarchive/libarchive/releases/download/v$version/$name-$version.tar.xz)
build() {
patch -Np1 -d $name-$version -i $SRC/lzma_stream.patch
cmake -S $name-$version -B build -G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr \
-D CMAKE_BUILD_TYPE=Release \
@ -24,6 +21,7 @@ build() {
-D ENABLE_TEST=OFF \
-D BUILD_TESTING=OFF \
-Wno-dev
cmake --build build -j ${JOBS:-1}
DESTDIR=$PKG cmake --install build
}

View File

@ -1,39 +0,0 @@
From 2ba3d92706384be14cd376734f3f7ebe5648591e Mon Sep 17 00:00:00 2001
From: alice <alice@ayaya.dev>
Date: Sat, 23 Sep 2023 01:57:55 +0200
Subject: [PATCH] fix detection of lzma_stream_encoder_mt with Werror (#1965)
the function is marked as warn-unused-result, so by default in a Debug
build with cmake, when Werror is set, this fails to detect. do the same
for autotools.
---
CMakeLists.txt | 2 +-
configure.ac | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc1fcc72a..6211fd8ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -523,7 +523,7 @@ IF(LIBLZMA_FOUND)
"#include <lzma.h>\nint main() {return (int)lzma_version_number(); }"
"WITHOUT_LZMA_API_STATIC;LZMA_API_STATIC")
CHECK_C_SOURCE_COMPILES(
- "#include <lzma.h>\n#if LZMA_VERSION < 50020000\n#error unsupported\n#endif\nint main(void){lzma_stream_encoder_mt(0, 0); return 0;}"
+ "#include <lzma.h>\n#if LZMA_VERSION < 50020000\n#error unsupported\n#endif\nint main(void){int ignored __attribute__((unused)); ignored = lzma_stream_encoder_mt(0, 0); return 0;}"
HAVE_LZMA_STREAM_ENCODER_MT)
IF(NOT WITHOUT_LZMA_API_STATIC AND LZMA_API_STATIC)
ADD_DEFINITIONS(-DLZMA_API_STATIC)
diff --git a/configure.ac b/configure.ac
index 67235c5d9..79a13b53d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -482,7 +482,7 @@ if test "x$with_lzma" != "xno"; then
[#if LZMA_VERSION < 50020000]
[#error unsupported]
[#endif]],
- [[lzma_stream_encoder_mt(0, 0);]])],
+ [[int ignored __attribute__((unused)); ignored = lzma_stream_encoder_mt(0, 0);]])],
[ac_cv_lzma_has_mt=yes], [ac_cv_lzma_has_mt=no])])
if test "x$ac_cv_lzma_has_mt" != xno; then
AC_DEFINE([HAVE_LZMA_STREAM_ENCODER_MT], [1], [Define to 1 if you have the `lzma_stream_encoder_mt' function.])

View File

@ -6,8 +6,8 @@ drwxr-xr-x root/root usr/include/nghttp2/
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libnghttp2.a
-rwxr-xr-x root/root usr/lib/libnghttp2.la
lrwxrwxrwx root/root usr/lib/libnghttp2.so -> libnghttp2.so.14.27.0
lrwxrwxrwx root/root usr/lib/libnghttp2.so.14 -> libnghttp2.so.14.27.0
-rwxr-xr-x root/root usr/lib/libnghttp2.so.14.27.0
lrwxrwxrwx root/root usr/lib/libnghttp2.so -> libnghttp2.so.14.28.0
lrwxrwxrwx root/root usr/lib/libnghttp2.so.14 -> libnghttp2.so.14.28.0
-rwxr-xr-x root/root usr/lib/libnghttp2.so.14.28.0
drwxr-xr-x root/root usr/lib/pkgconfig/
-rw-r--r-- root/root usr/lib/pkgconfig/libnghttp2.pc

View File

@ -1,5 +1,5 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVeqqxym8Ix8/V1nqu+4fk4hwoz6W4KkOCJ7u6BXhyr60q+s7r/iUd0P890KUVQmDt6a8GC6d/cWNQtyYyesMe+GQ8=
SHA256 (Pkgfile) = 58762e4606f29b517a09c7557366fb0102af0d4b7b93da8e2b9be6f4be3d7a85
SHA256 (.footprint) = 18c11899dd8b0f131d3846f9a846fb8eb35e23b041cf40f8c0b9f5bdedda1398
SHA256 (nghttp2-1.60.0.tar.xz) = 625d6c3da1d9ca4fd643a638256431ae68fd1901653b2a61a245eea7b261bf4e
RWRJc1FUaeVeqs7q1EtrBxVrluPp2xGyndX0oqDIa3ef2CrQfpK16NQVNntpYdyAMzof20Wr007aPjF5/s/chVfCRxUpgdOKuAc=
SHA256 (Pkgfile) = 3abedb1a92c3c227499059f2e928511681f0c4a962f4a671a35b92ff0994315e
SHA256 (.footprint) = 8a522659cfa1e8c911c8ae0ba1e8c44f812fcba0b59e066239c2e801b1392918
SHA256 (nghttp2-1.61.0.tar.xz) = c0e660175b9dc429f11d25b9507a834fb752eea9135ab420bb7cb7e9dbcc9654

View File

@ -3,7 +3,7 @@
# Maintainer: CRUX System Team, core-ports at crux dot nu
name=libnghttp2
version=1.60.0
version=1.61.0
release=1
source=(https://github.com/nghttp2/nghttp2/releases/download/v$version/nghttp2-$version.tar.xz)

View File

@ -15,12 +15,12 @@ lrwxrwxrwx root/root usr/bin/apropos -> whatis
-rwxr-xr-x root/root usr/bin/whatis
drwxr-xr-x root/root usr/lib/
drwxr-xr-x root/root usr/lib/man-db/
-rwxr-xr-x root/root usr/lib/man-db/libman-2.12.0.so
-rwxr-xr-x root/root usr/lib/man-db/libman-2.12.1.so
-rwxr-xr-x root/root usr/lib/man-db/libman.la
lrwxrwxrwx root/root usr/lib/man-db/libman.so -> libman-2.12.0.so
-rwxr-xr-x root/root usr/lib/man-db/libmandb-2.12.0.so
lrwxrwxrwx root/root usr/lib/man-db/libman.so -> libman-2.12.1.so
-rwxr-xr-x root/root usr/lib/man-db/libmandb-2.12.1.so
-rwxr-xr-x root/root usr/lib/man-db/libmandb.la
lrwxrwxrwx root/root usr/lib/man-db/libmandb.so -> libmandb-2.12.0.so
lrwxrwxrwx root/root usr/lib/man-db/libmandb.so -> libmandb-2.12.1.so
drwxr-xr-x root/root usr/lib/man-db/man-db/
-rwxr-xr-x root/root usr/lib/man-db/man-db/globbing
-rwxr-xr-x root/root usr/lib/man-db/man-db/manconv

View File

@ -1,6 +1,6 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVeqrOjayZLaRrGCuWx0k7rhXFXGCClSizJKh0c7Xiy42fDe2+Uuq7VN3MqrWPRtWL0nYa+zRCdER2nMN9AWeD2QgM=
SHA256 (Pkgfile) = 84948e3d1aac10c75d26251c4b776d3d7a8044d95206de89473821430d68c813
SHA256 (.footprint) = 0c391751c9d102f775d80110d76c799fa9ee333dde9ef596bc016f4c6091a42d
SHA256 (man-db-2.12.0.tar.xz) = 415a6284a22764ad22ff0f66710d853be7790dd451cd71436e3d25c74d996a95
RWRJc1FUaeVeqiPymOZrziZ2WVJIQCUA8z8IQiNebi0RO8e453l5RkL5SERsFCNPgYPntwrt7KbSXUupqDuMsz4pWtRFVTXbdwo=
SHA256 (Pkgfile) = 8a68bd36efac564b6330e48e7dce0e4091c779a9cb23fc2d48f17ef7692ac150
SHA256 (.footprint) = 8e730c6c41f323c9e39caa1ce261cd2dba69c159380ea050332e83d3ad7f8af2
SHA256 (man-db-2.12.1.tar.xz) = ddee249daeb78cf92bab794ccd069cc8b575992265ea20e239e887156e880265
SHA256 (mandb.cron) = f2e9f1210bf6b7c3335cc6f3a9551651812428109ea8c4adc9cd5cf73461e0f1

View File

@ -4,7 +4,7 @@
# Depends on: zlib gdbm libpipeline
name=man-db
version=2.12.0
version=2.12.1
release=1
source=(https://download.savannah.gnu.org/releases/$name/$name-$version.tar.xz
mandb.cron)

View File

@ -1,5 +1,5 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVeqjm35aUhc0hGWoxcyvS9WAr3HAkqqRXRQKnttWMZcn6tHXb8gwhxmF+IhsWaGZDHhcJUOVlIOtLT1MA/f79dRQw=
SHA256 (Pkgfile) = bf41dcda7b58caf4557414db8880aceffa3a8904ea5b7e9ebe50e82393dc9ae4
RWRJc1FUaeVeqvNPwxJtQ+2gPxGr4l2QIMuuglSOB2fjhmikBjlFRjM9qMmsg/+KY2dfr+dfhWxqMADyy3y4wpQ9Qv6FjRFwzQo=
SHA256 (Pkgfile) = 59e836d96c063dc30eb42ce671df7f3ee8c1dc309dfa5230682ca33a2872c950
SHA256 (.footprint) = 2f2595d48b1d9747afa0d6b676a290528c98d1151c567954c594803a07fa9255
SHA256 (nasm-2.16.01.tar.xz) = c77745f4802375efeee2ec5c0ad6b7f037ea9c87c92b149a9637ff099f162558
SHA256 (nasm-2.16.02.tar.xz) = 1e1b942ea88f22edae89659e15be26fa027eae0747f51413540f52d4eac4790d

View File

@ -3,7 +3,7 @@
# Maintainer: CRUX System Team, core-ports at crux dot nu
name=nasm
version=2.16.01
version=2.16.02
release=1
source=(https://www.nasm.us/pub/nasm/releasebuilds/$version/$name-$version.tar.xz)

View File

@ -10,8 +10,8 @@ drwxr-xr-x root/root usr/include/pci/
drwxr-xr-x root/root usr/lib/
-rw-r--r-- root/root usr/lib/libpci.a
lrwxrwxrwx root/root usr/lib/libpci.so -> libpci.so.3
lrwxrwxrwx root/root usr/lib/libpci.so.3 -> libpci.so.3.11.1
-rw-r--r-- root/root usr/lib/libpci.so.3.11.1
lrwxrwxrwx root/root usr/lib/libpci.so.3 -> libpci.so.3.12.0
-rw-r--r-- root/root usr/lib/libpci.so.3.12.0
drwxr-xr-x root/root usr/lib/pkgconfig/
-rw-r--r-- root/root usr/lib/pkgconfig/libpci.pc
drwxr-xr-x root/root usr/sbin/

View File

@ -1,5 +1,5 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVeqrbM4wMe6FvunxK+Rtm7q+3kAu0hE2UIWPCJfWWvSlw+ba8b9KiB15gdy4FI6ojTWRk6Fchcg035xuA6tMG7egk=
SHA256 (Pkgfile) = 6f917ae4c8b97a0b970b9bc135ba2ea67f60be6da33dce10d0e5a74a59167d0e
SHA256 (.footprint) = e2532be4e23138d437135c25b89e0dd85beeb479f883b3e41a19d5d1f6c03ce1
SHA256 (pciutils-3.11.1.tar.gz) = 1904864ce5b0272d0a2e42e72ceac9e8810d1898480567f36b70642f8205fbfd
RWRJc1FUaeVeqnwf1KrBSK4piYaR8zhAkaApzquAfTwQb7SWNFYYo+NQ62uq28gh7dOvc39WPX1oXcVFOhXUG3UMe84DiOrdbws=
SHA256 (Pkgfile) = 172ee05ee300a12b1a018c58a52bd6ca955dc7edeebfab2816b9c3f7ddff528c
SHA256 (.footprint) = 1e53548ce5ca44a920ed7d8c0dc7bd1304d51b782b4605b136622a73db11d3c8
SHA256 (pciutils-3.12.0.tar.gz) = 827a641d2016a15f0b959804daa5a05f055d0f91d58a70d32ac41ce7ef94164e

View File

@ -4,7 +4,7 @@
# Depends on: eudev
name=pciutils
version=3.11.1
version=3.12.0
release=1
source=(https://mj.ucw.cz/download/linux/pci/$name-$version.tar.gz)

View File

@ -1,8 +1,8 @@
untrusted comment: verify with /etc/ports/core.pub
RWRJc1FUaeVeqvP+V1yQQB+h+GlUDxn9gyqg9hYAHLbb/M01ReKN9buJARO+k2mE/Y/AggQgfLX2WLmAPHzt68wVXkOjcafGQwA=
SHA256 (Pkgfile) = 1233b4c1242b298eca084d67479919120fcef93465977fb7160b3b1f603d1652
RWRJc1FUaeVeqmdOSqH4Bah1Lk+3wJ70FWwJmUwXxSx/Kg+1BjXD4fQGMvxlsSPqxHpZtuWNegoUnK7J1fi0tPFlhcHnJPvD9AI=
SHA256 (Pkgfile) = 4e87a6a2c95292d43004539646b38079ef6df199b21ae5c714be91ae82fb3353
SHA256 (.footprint) = bf468272af3c29c8b4b4d150730c23071cf0093dc06172548b7dbddaeee6c3c3
SHA256 (rsync-3.2.7.tar.gz) = 4e7d9d3f6ed10878c58c5fb724a67dacf4b6aac7340b13e488fb2dc41346f2bb
SHA256 (rsync-3.3.0.tar.gz) = 7399e9a6708c32d678a72a63219e96f23be0be2336e50fd1348498d07041df90
SHA256 (rsyncd.conf) = ada548bd0ff96a02dea1fc58dd3d0821027526c4f3cd1a35dcaf30b22dc02c7e
SHA256 (rsyncd) = 424dbf7cbe8d4f60a1868984084d107445a3dd33c77a82eb36598f012204946a
SHA256 (rsync.driver) = 5e0f94a972cf7e47f153ccd0ac454ec2bd3056a834b69e82d3f3984d44308ef7

View File

@ -4,7 +4,7 @@
# Depends on: acl openssl zlib zstd
name=rsync
version=3.2.7
version=3.3.0
release=1
source=(https://download.samba.org/pub/rsync/$name-$version.tar.gz \
rsyncd.conf rsyncd rsync.driver)