sysvinit: use execle() instead of execl().
The caller wants to set the environment, so we need to use execle().
This commit is contained in:
parent
96233d679d
commit
cdaa387d44
@ -1,2 +1,2 @@
|
||||
51a9e5dabf3203b0a41e8f58477517ed sysvinit-2.86.patch
|
||||
db5fc89c347b6c9a5a9e94e0eeadf49e sysvinit-2.86.patch
|
||||
7d5d61c026122ab791ac04c8a84db967 sysvinit-2.86.tar.gz
|
||||
|
@ -4,7 +4,7 @@
|
||||
|
||||
name=sysvinit
|
||||
version=2.86
|
||||
release=5
|
||||
release=6
|
||||
source=(ftp://ftp.cistron.nl/pub/people/miquels/sysvinit/$name-$version.tar.gz \
|
||||
$name-$version.patch)
|
||||
|
||||
|
@ -75,3 +75,15 @@ diff -ru sysvinit-2.86/src/Makefile sysvinit-2.86-new/src/Makefile
|
||||
done
|
||||
ifeq ($(ROOT),)
|
||||
#
|
||||
diff -aur sysvinit-2.86.orig/src/init.c sysvinit-2.86/src/init.c
|
||||
--- sysvinit-2.86.orig/src/init.c 2004-07-30 14:16:20.000000000 +0200
|
||||
+++ sysvinit-2.86/src/init.c 2010-07-23 16:32:36.679827761 +0200
|
||||
@@ -1884,7 +1884,7 @@
|
||||
* The existing init process execs a new init binary.
|
||||
*/
|
||||
env = init_buildenv(0);
|
||||
- execl(myname, myname, "--init", NULL, env);
|
||||
+ execle(myname, myname, "--init", NULL, env);
|
||||
|
||||
/*
|
||||
* We shouldn't be here, something failed.
|
||||
|
Loading…
x
Reference in New Issue
Block a user