core/openssl/openssl-0.9.8b-parallel-build.patch
2006-09-06 10:10:20 +00:00

27 lines
699 B
Diff

Parallel make fix, from
http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-libs/openssl/files/
--- openssl-0.9.8b/Makefile.org
+++ openssl-0.9.8b/Makefile.org
@@ -229,15 +229,15 @@
build_crypto:
@dir=crypto; target=all; $(BUILD_ONE_CMD)
-build_ssl:
+build_ssl: build_crypto
@dir=ssl; target=all; $(BUILD_ONE_CMD)
-build_engines:
+build_engines: build_crypto
@dir=engines; target=all; $(BUILD_ONE_CMD)
-build_apps:
+build_apps: build_libs
@dir=apps; target=all; $(BUILD_ONE_CMD)
-build_tests:
+build_tests: build_libs
@dir=test; target=all; $(BUILD_ONE_CMD)
-build_tools:
+build_tools: build_libs
@dir=tools; target=all; $(BUILD_ONE_CMD)
all_testapps: build_libs build_testapps