core/lilo/lilo-config.patch

52 lines
1.8 KiB
Diff

diff -Nru lilo-23.0.orig/make.vars lilo-23.0/make.vars
--- lilo-23.0.orig/make.vars 2010-07-15 21:39:54.965407096 +0200
+++ lilo-23.0/make.vars 2010-07-15 21:40:57.575406190 +0200
@@ -64,14 +64,14 @@
# XL_SECS=n Support for extra large (non-standard) floppies.
CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
- -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVIRTUAL \
-DMDPRAID -DDEVMAPPER
# set the following if you wish LILO.COM to be installed
DOS_DIR=/dosC/boot
# select place for man pages
-MAN_DIR=/usr/share/man
+MAN_DIR=/usr/man
# set the compiler optimization level
OPT=-Os
diff -Nru lilo-23.0.orig/man/Makefile lilo-23.0/man/Makefile
--- lilo-23.0.orig/man/Makefile 2010-07-15 21:39:54.965407096 +0200
+++ lilo-23.0/man/Makefile 2010-07-15 21:52:36.175405918 +0200
@@ -8,7 +8,6 @@
install:
mkdir -p $$DESTDIR$(MAN_DIR)/man5 $$DESTDIR$(MAN_DIR)/man8
cp lilo.8 $$DESTDIR$(MAN_DIR)/man8
- cp mkrescue.8 $$DESTDIR$(MAN_DIR)/man8
cp lilo.conf.5 $$DESTDIR$(MAN_DIR)/man5
cp keytab-lilo.8 $$DESTDIR$(MAN_DIR)/man8
diff -Nru lilo-23.0.orig/src/Makefile lilo-23.0/src/Makefile
--- lilo-23.0.orig/src/Makefile 2010-07-15 21:39:54.985406163 +0200
+++ lilo-23.0/src/Makefile 2010-07-15 21:52:55.195406033 +0200
@@ -41,7 +41,7 @@
#
# everything needed to run, just short of installation
#
-all: lilo bootsect.b diag1.img
+all: lilo
#
# everything above plus the statically linked version
@@ -257,7 +257,6 @@
rm -f $$DESTDIR$(BOOT_DIR)/boot.b; fi
cp lilo $$DESTDIR$(SBIN_DIR)/lilo
strip $$DESTDIR$(SBIN_DIR)/lilo
- cp ../mkrescue $$DESTDIR$(USRSBIN_DIR)/mkrescue
cp ../keytab-lilo.pl $$DESTDIR$(USRSBIN_DIR)/keytab-lilo
insobs: