wvdial: removed

This commit is contained in:
Juergen Daubert 2019-02-03 12:57:31 +01:00
parent 3be50020e1
commit 1cdd6006f2
8 changed files with 0 additions and 245 deletions

View File

@ -1,16 +0,0 @@
drwxr-xr-x root/root etc/
drwxr-xr-x root/root etc/ppp/
drwxr-xr-x root/root etc/ppp/peers/
-rw-r--r-- root/root etc/ppp/peers/wvdial
-rw-r--r-- root/root etc/ppp/peers/wvdial-pipe
drwxr-xr-x root/root usr/
drwxr-xr-x root/root usr/bin/
-rwxr-xr-x root/root usr/bin/wvdial
-rwxr-xr-x root/root usr/bin/wvdialconf
drwxr-xr-x root/root usr/share/
drwxr-xr-x root/root usr/share/man/
drwxr-xr-x root/root usr/share/man/man1/
-rw-r--r-- root/root usr/share/man/man1/wvdial.1.gz
-rw-r--r-- root/root usr/share/man/man1/wvdialconf.1.gz
drwxr-xr-x root/root usr/share/man/man5/
-rw-r--r-- root/root usr/share/man/man5/wvdial.conf.5.gz

View File

@ -1,11 +0,0 @@
untrusted comment: verify with /etc/ports/opt.pub
RWSE3ohX2g5d/VuV3BVTxOuSKR88kyH0dxR22HoBpMvKRyA8fDI6x9tEq0xuiC9rq+K3+AeU1BycDgI1GgGaWXMyoAugP8kD2w4=
SHA256 (Pkgfile) = 4e8d66d2271654e18cec732fb5c19d41196b6de2e7d51ab99ee417c70ff7ea4f
SHA256 (.footprint) = da2e272efbd29ba47e1977735e8cd01722db61ba7a42726f0c4286c3efa9fd64
SHA256 (wvdial-1.61.tar.gz) = 4fffab9652c760199c074533d1d3929bea55ab4233b11e735b0f1856d1ceec57
SHA256 (wvstreams-4.6.1.tar.gz) = 8403f5fbf83aa9ac0c6ce15d97fd85607488152aa84e007b7d0621b8ebc07633
SHA256 (wvdial-1.61.patch) = e42a16403a259e152234389f14434fc8be0d1dfce66454cd3bc4f756dfb78dcc
SHA256 (wvstreams-4.6.1-openssl.patch) = 12557e00efc1de8e121d2eb02ab2febd7eb14313b6c7f0b17ccdcb07afff332b
SHA256 (wvstreams-4.6.1-include_stat.patch) = 9a6e3885a2c88e5f01ff30e09417af170567d970037874842c9ed7dc4f571ed1
SHA256 (wvstreams-4.6.1-gcc47.patch) = 8177359dc0aefa2e17f41b47f11694dd0fbc9fbd7dcba095b662322bedc4437d
SHA256 (wvstreams-4.6.1-use-explicit-cast.patch) = d29756fdbc17d4b92512e767a1eeb99899c442746c7fc07370a3012966d8d895

View File

@ -1,41 +0,0 @@
# Description: Weave Dial - PPP dialer
# URL: https://code.google.com/archive/p/wvstreams/
# Maintainer: Juergen Daubert, jue at crux dot nu
# Depends on: ppp
name=wvdial
version=1.61
release=7
source=(https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/wvstreams/$name-$version.tar.gz \
https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/wvstreams/wvstreams-4.6.1.tar.gz \
$name-$version.patch \
wvstreams-4.6.1-openssl.patch \
wvstreams-4.6.1-include_stat.patch \
wvstreams-4.6.1-gcc47.patch \
wvstreams-4.6.1-use-explicit-cast.patch)
build() {
sed -i 's/-D_BSD_SOURCE/-D_DEFAULT_SOURCE/' */wvrules.mk
cd wvstreams-4.6.1
patch -p1 -i $SRC/wvstreams-4.6.1-use-explicit-cast.patch
patch -p1 -i $SRC/wvstreams-4.6.1-openssl.patch
patch -p1 -i $SRC/wvstreams-4.6.1-include_stat.patch
patch -p1 -i $SRC/wvstreams-4.6.1-gcc47.patch
./configure --prefix=/usr --without-{pam,tcl,qt,dbus}
CXXOPTS='-fno-tree-dce -fno-optimize-sibling-calls -fPIC -DPIC -w' \
COPTS='-O2 -fPIC -DPIC' \
make -j1
cd $SRC/$name-$version
patch -p1 -i $SRC/$name-$version.patch
./configure
make -j1 WVS=$SRC/wvstreams-4.6.1
make DESTDIR=$PKG install
}

View File

@ -1,70 +0,0 @@
diff -Nru wvdial-1.61.orig/Makefile.in wvdial-1.61/Makefile.in
--- wvdial-1.61.orig/Makefile.in 2016-10-29 12:11:27.722154180 +0200
+++ wvdial-1.61/Makefile.in 2016-10-29 12:12:31.096513061 +0200
@@ -3,27 +3,19 @@
WVPACKAGE_TARNAME=@PACKAGE_TARNAME@
WVPACKAGE_VERSION=@PACKAGE_VERSION@
-prefix=/usr/local
-WVSTREAMS_INC=
-WVSTREAMS_LIB=
+prefix=$(DESTDIR)/usr
+WVSTREAMS_INC=$(WVS)/include
+WVSTREAMS_LIB=$(WVS)
WVSTREAMS_BIN=$(prefix)/bin
WVSTREAMS_SRC=.
-PC_CFLAGS=$(shell pkg-config --cflags libwvstreams)
-ifeq ($(PC_CFLAGS),)
- $(error WvStreams does not appear to be installed)
-endif
-CPPFLAGS+=$(PC_CFLAGS)
-
-PC_LIBS=$(shell pkg-config --libs libwvstreams)
-ifeq ($(PC_LIBS),)
- $(error WvStreams does not appear to be installed)
-endif
-LIBS+=$(PC_LIBS)
+LIBS = $(WVS)/libwvstatic.a -lstdc++ -lcrypto -lssl
BINDIR=${prefix}/bin
MANDIR=${prefix}/share/man
-PPPDIR=/etc/ppp/peers
+PPPDIR=$(DESTDIR)/etc/ppp/peers
+
+VERBOSE=1
include wvrules.mk
@@ -33,9 +25,6 @@
wvdial.a: wvdialer.o wvmodemscan.o wvpapchap.o wvdialbrain.o \
wvdialmon.o
-wvdial wvdialconf papchaptest pppmon: \
- LDFLAGS+=-luniconf -lwvstreams -lwvutils -lwvbase
-
wvdial wvdialconf papchaptest pppmon: wvdial.a
install-bin: all
diff -Nru wvdial-1.61.orig/config.defaults.mk wvdial-1.61/config.defaults.mk
--- wvdial-1.61.orig/config.defaults.mk 2016-10-29 12:11:27.722154180 +0200
+++ wvdial-1.61/config.defaults.mk 2016-10-29 12:11:55.997788968 +0200
@@ -13,7 +13,6 @@
LIBS_PAM=-lpam
LIBS_TCL=
-prefix=/usr/local
datadir=${prefix}/share
includedir=${prefix}/include
infodir=${prefix}/share/info
@@ -28,8 +27,8 @@
libexecdir=${exec_prefix}/libexec
sbindir=${exec_prefix}/sbin
-enable_debug=yes
-enable_optimization=no
+enable_debug=no
+enable_optimization=yes
enable_resolver_fork=
enable_warnings=
enable_testgui=

View File

@ -1,12 +0,0 @@
# http://code.google.com/p/wvstreams/issues/detail?id=34
--- wvstreams-4.6.1-dist/include/wvuid.h 2012-01-05 10:18:58.713661236 +0100
+++ wvstreams-4.6.1/include/wvuid.h 2012-01-05 10:27:42.198435328 +0100
@@ -7,6 +7,7 @@
#ifndef __WVUID_H
#define __WVUID_H
+#include <unistd.h>
#include "wvstring.h"
#if WIN32

View File

@ -1,27 +0,0 @@
# http://code.google.com/p/wvstreams/issues/detail?id=28
diff -Nru wvstreams-4.6.1.orig/ipstreams/wvunixdgsocket.cc wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc
--- wvstreams-4.6.1.orig/ipstreams/wvunixdgsocket.cc 2010-08-05 18:19:24.572113629 +0200
+++ wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc 2010-08-05 18:19:54.071829657 +0200
@@ -1,8 +1,6 @@
#include "wvunixdgsocket.h"
-#ifdef MACOS
#include <sys/types.h>
#include <sys/stat.h>
-#endif
WvUnixDGSocket::WvUnixDGSocket(WvStringParm filename, bool _server, int perms)
: socketfile(filename)
diff -Nru wvstreams-4.6.1.orig/streams/wvatomicfile.cc wvstreams-4.6.1/streams/wvatomicfile.cc
--- wvstreams-4.6.1.orig/streams/wvatomicfile.cc 2010-08-05 18:19:24.582113531 +0200
+++ wvstreams-4.6.1/streams/wvatomicfile.cc 2010-08-05 18:20:22.271557390 +0200
@@ -11,9 +11,7 @@
#include "wvfileutils.h"
#include "wvstrutils.h"
-#ifdef MACOS
#include <sys/stat.h>
-#endif
WvAtomicFile::WvAtomicFile(WvStringParm filename, int flags, mode_t create_mode)
: tmp_file(WvString::null)

View File

@ -1,18 +0,0 @@
# http://code.google.com/p/wvstreams/issues/detail?id=27
--- wvstreams-4.6.1/crypto/wvx509.cc 2008-10-23 22:23:49.000000000 +0200
+++ wvstreams-4.6.1-1/crypto/wvx509.cc 2010-01-27 11:09:06.000000000 +0100
@@ -1157,7 +1157,11 @@
if (ext)
{
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
+ const X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
+#else
X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
+#endif
if (!method)
{
WvDynBuf buf;

View File

@ -1,50 +0,0 @@
From 32ecfa8e89306ace726f7ad14f2b09c2aa1b96c4 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Tue, 9 Feb 2016 21:02:59 +0100
Subject: [PATCH] Use explicit cast and prevent compiler error
---
streams/wvstream.cc | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)
diff --git a/streams/wvstream.cc b/streams/wvstream.cc
index 4564f3c..76565b4 100644
--- a/streams/wvstream.cc
+++ b/streams/wvstream.cc
@@ -907,9 +907,9 @@ void WvStream::_build_selectinfo(SelectInfo &si, time_t msec_timeout,
if (forceable)
{
- si.wants.readable = readcb;
- si.wants.writable = writecb;
- si.wants.isexception = exceptcb;
+ si.wants.readable = static_cast<bool>(readcb);
+ si.wants.writable = static_cast<bool>(writecb);
+ si.wants.isexception = static_cast<bool>(exceptcb);
}
else
{
@@ -1019,7 +1019,7 @@ bool WvStream::_select(time_t msec_timeout, bool readable, bool writable,
IWvStream::SelectRequest WvStream::get_select_request()
{
- return IWvStream::SelectRequest(readcb, writecb, exceptcb);
+ return IWvStream::SelectRequest(static_cast<bool>(readcb), static_cast<bool>(writecb), static_cast<bool>(exceptcb));
}
@@ -1107,7 +1107,10 @@ bool WvStream::continue_select(time_t msec_timeout)
// inefficient, because if the alarm was expired then pre_select()
// returned true anyway and short-circuited the previous select().
TRACE("hello-%p\n", this);
- return !alarm_was_ticking || select(0, readcb, writecb, exceptcb);
+ return !alarm_was_ticking || select(0,
+ static_cast<bool>(readcb),
+ static_cast<bool>(writecb),
+ static_cast<bool>(exceptcb));
}
--
2.5.0