opt/python/python-2.5.patch

55 lines
2.0 KiB
Diff

diff -Nru Python-2.5.orig/Lib/cgi.py Python-2.5/Lib/cgi.py
--- Python-2.5.orig/Lib/cgi.py 2007-01-03 14:31:57.000000000 +0100
+++ Python-2.5/Lib/cgi.py 2007-01-03 14:32:13.000000000 +0100
@@ -1,4 +1,4 @@
-#! /usr/local/bin/python
+#! /usr/bin/python
# NOTE: the above "/usr/local/bin/python" is NOT a mistake. It is
# intentionally NOT "/usr/bin/env python". On many systems
diff -Nru Python-2.5.orig/Makefile.pre.in Python-2.5/Makefile.pre.in
--- Python-2.5.orig/Makefile.pre.in 2007-01-03 14:32:02.000000000 +0100
+++ Python-2.5/Makefile.pre.in 2007-01-03 14:32:33.000000000 +0100
@@ -62,7 +62,7 @@
# be able to build extension modules using the directories specified in the
# environment variables
CPPFLAGS= -I. -I$(srcdir)/Include @CPPFLAGS@
-LDFLAGS= @LDFLAGS@
+LDFLAGS= -L. @LDFLAGS@
LDLAST= @LDLAST@
SGI_ABI= @SGI_ABI@
CCSHARED= @CCSHARED@
diff -Nru Python-2.5.orig/Modules/Setup.dist Python-2.5/Modules/Setup.dist
--- Python-2.5.orig/Modules/Setup.dist 2007-01-03 14:32:02.000000000 +0100
+++ Python-2.5/Modules/Setup.dist 2007-01-03 14:32:13.000000000 +0100
@@ -149,7 +149,7 @@
# modules are to be built as shared libraries (see above for more
# detail; also note that *static* reverses this effect):
-#*shared*
+*shared*
# GNU readline. Unlike previous Python incarnations, GNU readline is
# now incorporated in an optional module, configured in the Setup file
@@ -381,7 +381,7 @@
#
# First, look at Setup.config; configure may have set this for you.
-#dbm dbmmodule.c # dbm(3) may require -lndbm or similar
+dbm dbmmodule.c -DHAVE_NDBM_H -lgdbm_compat -lgdbm # dbm(3) may require -lndbm or similar
# Anthony Baxter's gdbm module. GNU dbm(3) will require -lgdbm:
#
diff -Nru Python-2.5.orig/configure Python-2.5/configure
--- Python-2.5.orig/configure 2007-01-03 14:31:58.000000000 +0100
+++ Python-2.5/configure 2007-01-03 14:32:13.000000000 +0100
@@ -3800,7 +3800,7 @@
# debug builds.
OPT="-g -Wall $STRICT_PROTO"
else
- OPT="-g -O3 -Wall $STRICT_PROTO"
+ OPT="$CFLAGS -Wall $STRICT_PROTO"
fi
;;
*)